
ScanMap Software 
User Manual

Manual No. 50265564, Rev. 03



Important Information

Terms Used in this Manual

CAUTION Indicates actions or procedures which may lead to incorrect function of the instrument or con-
nected equipment if not performed correctly.

Important Indicates actions or procedures which may affect instrument operation or may lead to an instru-
ment response which is not planned.

*Mark of Schlumberger.

Other company, product, and service names are the properties of their respective owners.

Copyright © 2017 Schlumberger Limited. All rights reserved.

Manual No. 50265564, Rev. 03 
November 2017



iii

ScanMap  Table of Contents

Contents

Important Information ..........................................................................................................................................ii

Section 1—Getting Started ...............................................................................................................5
Introduction ......................................................................................................................................................... 5
Installation Preparations ..................................................................................................................................... 6

Firmware/Software Compatibility ................................................................................................................. 6
Installation .................................................................................................................................................... 6

Section 2—Navigating the Software ................................................................................................7
Main Screen ....................................................................................................................................................... 7

Toolbar ......................................................................................................................................................... 8
Edit Registers Screen ......................................................................................................................................... 8
General Options Screen ..................................................................................................................................... 9

Section 3—Configurable Options ..................................................................................................11
Choosing SI Units or US Customary Units ........................................................................................................11
Changing Units and Rates of Measurement......................................................................................................11

Applying Changes to All Registers ............................................................................................................. 12
Changing Directories for Database Map and Manual Files .............................................................................. 12
Changing Input Names ..................................................................................................................................... 12
Changing Analog Input and Pulse Input Categories ......................................................................................... 13
Reducing the Map File Size.............................................................................................................................. 13

Section 4—Creating Databases and Configuring Register Maps ...............................................15
Creating a New Database ................................................................................................................................ 16

Firmware Verification ................................................................................................................................. 17
Creating a New Database from an Existing Database ..................................................................................... 17
Editing an Existing Database............................................................................................................................ 18
Configuring a Custom Map ............................................................................................................................... 19

Selecting Registers from Each Group ........................................................................................................ 20

Section 5—Creating and Uploading a Modbus Map ....................................................................23
Creating a Manual Only .................................................................................................................................... 23
Creating a Map and Manual ............................................................................................................................. 25

Backup Database Files  ............................................................................................................................. 26
Uploading a Map to the Scanner 3100 ............................................................................................................. 27

ScanFlash .................................................................................................................................................. 27
Scanner 3100 Web Interface ..................................................................................................................... 29

Section 6—Map/Register Maintenance..........................................................................................31
Changing the Map Name.................................................................................................................................. 31
Changing the Firmware Version ....................................................................................................................... 31
Standardizing Units in a Database ................................................................................................................... 32
Restoring Units to Default Settings................................................................................................................... 32
Restoring a Custom Database File from a Backup File.................................................................................... 33

Backup Database Files .............................................................................................................................. 33
Database Restoration ................................................................................................................................ 33

Restoring a Factory Default Database ............................................................................................................. 33

Section 7—Technical Support ........................................................................................................35



This page is left blank intentionally.

iv

Table of Contents ScanMap



Section 1—Getting Started

Introduction
The ScanMap* software simplifies the integration of the Scanner 3100 into a SCADA network by enabling the custom-
ization of Modbus registers. A user can build a custom Modbus map from scratch and upload it to a Scanner 3100 or 
modify an existing map. ScanMap is preloaded with three protocol maps that can be used as-is or modified with user-se-
lected registers and units:

• S3100_MAP_TEMPLATE_ENRON_DEFAULT. Includes registers for Scanner 3100 and up to 20 networked Scanner 
2000 series devices. Enron history is included.

• S3100_MAP_TEMPLATE_ENRON_BASE_UNIT. Includes registers for the Scanner 3100 only. Networked Scanner 
2000 series devices are not included. Enron history is included.

• S3100_MAP_TEMPLATE_MODBUS. This custom map is equivalent to the S3100_MAP_TEMPLATE_ENRON_
DEFAULT (32-bit) map, but is presented in a 16-bit standard Modbus format and contains different register addresses. 
Enron history is not included.

Important  First-time ScanMap users are strongly encouraged to first review Sections 2 and 3 to learn about 
the software settings available and configurable software default settings that can save time in 
creating a custom map. Instructions for creating and uploading a Modbus map are provided in 
Section 4—Creating Databases and Configuring Register Maps, page 15 and Section 5—Creating and 
Uploading a Modbus Map, page 23. 

CAUTION  Before editing an existing database, make certain that it is your intent to permanently change the 
contents. Any changes you make to an existing database will overwrite database content without 
any prompts to save or cancel.  
 
To use an existing database as the starting point for a new database without altering the existing 
database, choose File>New from Existing and save the file with a unique name. See Creating a New 
Database from an Existing Database, page 17, for details. 
 
If changes are made to a preloaded protocol map unintentionally, follow the procedures in Restor-
ing a Factory Default Database, page 33 to restore the preloaded protocol map(s). 

To create a custom Modbus map, users will create two files: a database (.smp) file and a custom map (.pmap) file.

 • The database file (.smp) is an editable file used to collect and define the registers needed for export to the custom 
map. 

 • The custom map (.pmap) is a binary (uneditable) file, which can be uploaded to the Scanner 3100 via Cameron’s 
ScanFlash* software utility.

If desired, the user may also create a manual file (.html) to share map content in a user-friendly format that is easily 
emailed or printed.

Important  Users must have Configurator or Administrator level access to upload a map file to the Scanner 
3100. Access levels are assigned using the Scanner 3100 Web Interface. See the Scanner 3100 Web 
Interface User Manual for details about security administration. 
 
A custom map (.pmap) can also be uploaded using the Scanner 3100 web interface. See the Scan-
ner 3100 Web Interface user manual for details.
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Installation Preparations
Verify that the computer on which the software is being installed meets the following requirements:

Table 1.1—Installation Requirements
System Parameter Requirement(s)

Operating System Windows® 7 or later

Processor 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor

Memory 256 MB RAM

Hard Disk Space 50 MB for program files, adequate space for data files

Display DirectX 9 graphics 4 with WDDM 1.0 or later 

Important Before attempting to install ScanMap software, ensure that you have local administrator rights to 
the computer on which the software is to be installed. If the installation is blocked, contact your 
Information Technology department for assistance. 

Firmware/Software Compatibility
Consider the firmware version of the Scanner 3100 you are using before installing the ScanMap software.

 • ScanMap software versions 1.1.0 or later supports Scanner 3100 firmware versions 2.000 and later.

 • ScanMap version 1.0.0 supports Scanner 3100 firmware versions 1.100 and 1.103.

Installation
To install the software,

1. Visit Cameron’s Measurement website at products.slb.com/flowcomputers, select Scanner 3100 Series Wired and
Wireless and click on the ScanMap install link. A zip file will be downloaded to your laptop or PC.

2. Unzip/extract the installation folder.

3. Open the unzipped installation folder and run the “setup.exe” file. When the installation is complete, a ScanMap
desktop shortcut will appear on the computer desktop (Figure 1.1).

ScanMap

Figure 1.1—ScanMap desktop shortcut 
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Section 2—Navigating the Software
This section provides an overview of the ScanMap software tools and screens. For step-by-step instructions, see  
Section 3—Configurable Options, page 11 through Section 6—Map/Register Maintenance, page 31.

Note For best viewing, configure your computer display resolution to 1280 × 800 or higher. If a lower resolution is 
used, portions of the ScanMap interface may be hidden from view.

Main Screen
The ScanMap main screen (Figure 2.1) is divided into a top section and a bottom section. A toolbar at the top of the 
screen provides access to user menus. The status bar at the bottom of the screen displays the path to the open database 
file, the firmware version, and the computer date and time. 

Note When the software is opened from the desktop icon or the Windows Start menu, the main screen contains only 
a toolbar. When the software is opened by double-clicking on a database (.smp) file, the main screen will reflect 
the contents of the .smp file.

The top section allows the user to enter setup information for a register group, which is the first step in creating a cus-
tom map after a database is selected or created. This section also provides a link for changing firmware compatibility, 
which allows users to quickly create maps for multiple Scanner firmware versions without rebuilding register groups.

The bottom section displays the registers within a selected group and provides links for editing registers and creating a 
custom map and/or manual.

TOP SECTION
BOTTOM SECTION

 
Figure 2.1—Main screen
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Toolbar
The toolbar at the top of the main screen (Figure 2.1, page 7) provides access to three menus:

 • File. Use this menu to create, open, or change a database. See Section 4—Creating Databases and Configuring Reg-
ister Maps, page 15, for details.

 • Options. Use this menu to change a map name or access the General Options screen (see Section 3—Configurable 
Options, page 11 for information about setting options from this screen).

 • Help. Use this menu to access information about ScanMap’s technical support and license agreement or to access the 
user manual. See Section 7—Technical Support, page 35 for details.

Edit Registers Screen
Click the Edit Registers button on the main screen (Figure 2.1, page 7) to open the Edit Registers screen (Figure 
2.2), where you can add, edit, or remove registers from the selected group. Registers with a dynamic category and units 
can be modified on a register-by-register basis. See Section 3—Configurable Options, page 11, Section 4—Creating 
Databases and Configuring Register Maps, page 15, and Section 5—Creating and Uploading a Modbus Map, page 
23 for detailed instructions for building a custom map.

Figure 2.2—Edit Registers screen
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General Options Screen
Choosing Options>General Options from the main screen opens the General Options screen.

From the General Options screen (Figure 2.3, page 9), you can perform the following tasks:

• Change default units to SI Units or US Customary

• Change the units for a selected measurement category

• Change default directories for database, map and manual files

• Change input names for easy recognition

• Change analog input and pulse input categories to specify the type of measurement they will provide (pressure, 
temperature, level, etc.)

See Section 3—Configurable Options, page 11, for detailed instructions about customizing general options.

 
Figure 2.3—General Options screen
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Section 3—Configurable Options
Configure preferred units, register names, etc. from the General Options screen (Figure 3.1) before creating a new data-
base to simplify the process of creating the map.

Note  Input register name changes will not apply to registers that have already been added to a group. For best results, 
make input register name changes before creating a database. 

Figure 3.1—General Options screen configuration options

Choosing SI Units or US Customary Units
To change units of measure from SI Units to US Customary (or vice versa), click the SI Units or US Customary buttons 
located in the “Default all to” section of the screen, then click OK to save your changes.

Changing Units and Rates of Measurement
The Scanner 3100 pairs Modbus registers with measurement categories and assigns a unit to each category. In addition to 
supporting SI Units and US Customary units, ScanMap allows a combination of SI Units and US Customary units within 
a database. To change the unit of measure for an individual category:

1. Click in the “Units” field next to the measurement category on the General Options screen.

2. Select the desired unit of measure from the dropdown list.

For example, to change the default unit system to US Customary, but display the temperature displayed in °K, select US 
Customary as the “Default all to” selection and then select °K from the dropdown list in the temperature “Units” field. 
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If the data being polled include rates, the scalar setting displayed to the right of the unit will determine the rate. To 
change the rate scalar for an individual category:

1. Click in the “Scalar for Rate” field next to the measurement category.

2. Select the desired scalar from the dropdown list.

3. Click OK to save changes.

For example, to measure liquid volume in bbl per hour (instead of the “per day” default setting), click in the “Scalar for 
Rate” field next to Liquid Volume and select per hour from the dropdown list. Reference Figure 3.1, page 11, for 
assistance.

Note  Scalars apply only to registers that are indicators of rate. Scalar settings for all other measurements are not edit-
able.

Applying Changes to All Registers
By default, the changes made to units and rates apply only to new registers added to the currently open database. To ap-
ply these changes to all registers in a database, check the Apply to All Registers checkbox in the top left corner of the 
General Options screen (Figure 3.1, page 11) and click OK to save changes.

Note The Apply to All Registers checkbox will only appear after a database has been created.

Changing Directories for Database Map and Manual Files
By default, ScanMap stores database files (.smp), Modbus maps (.pmap) and Modbus manuals (.html), as well as backup 
datafiles (.sbck) on the user’s hard drive in the following directories:

• C:\Cameron Data\ScanMap\Configurations [database (.smp) files]

• C:\Cameron Data\ScanMap\Maps [Modbus maps (.pmap), backup database files (.sbck) and manual (.html) files]

To change the locations of these files, 

1. Click in the appropriate field in the “Default Directories” section of the General Options screen.

2. Type the desired filepath (if known) or click on the folder next to the field and browse to the desired location.

3. Click OK to save changes.

Note You will also be prompted to choose a filepath when saving maps and manuals.

Changing Input Names
By default, inputs have generic names. For easier identification, rename inputs by changing the entries in the “Input Cat-
egories” table on the General Options screen (Figure 3.1, page 11).

To change an input name, click in the “Input Name” field and enter the desired name. The new name will appear in all 
new input registers added to a group. Click OK to save changes.

 Note Changing an input name will not change the name of inputs previously added to a group.
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Changing Analog Input and Pulse Input Categories
To change analog input and pulse input categories,

1. From the “Input Categories” section of the General Options screen, click in the “Category” field next to the analog 
input or pulse input you wish to change.

2. Select the desired measurement category from the dropdown list.

Note  When a pulse input is configured for gas volume measurement, it is necessary to specify a calibration type (K-
factor or meter factor) as well. 

3. Repeat Steps 1 and 2 until all desired analog input and/or pulse input categories are changed.

4. Click OK to save changes.

Note Changing the input categories only applies to new registers; however, once the categories are set, the previously 
assigned registers can be automatically updated. For more information, see Standardizing Units in a Database 
and Restoring Units to Default Settings, page 32.

Reducing the Map File Size
Map file size is dependent on the number of groups in a database. If the map file size exceeds the Scanner’s upload ca-
pacity, ScanMap will prompt you with the following error message (Figure 3.2).

Figure 3.2—”Data is too large” error message

Should this error occur, reduce the number of groups in the file.

Note Deleting individual registers within groups has negligible effect on file size.

To further reduce file size, ensure that the Make Manual Viewable in Web Interface checkbox at the bottom of the Gen-
eral Options screen is unchecked (Figure 3.1, page 11). The manual (.html file) is accessible from the Maps output 
folder (C:\Cameron Data\ScanMap\Maps, by default) and can be shared via email if desired.
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Section 4—Creating Databases and Configuring Register Maps
The first step in creating a custom Modbus map is to build a custom database. From the File menu, ScanMap users can 
create a new database from scratch (File>New Database) or from an existing database (File>New from Existing), as 
shown in Figure 4.1. ScanMap is preloaded with three databases that can be used as-is or modified with user-selected 
registers and units:

• S3100_MAP_TEMPLATE_ENRON_DEFAULT. Includes registers for Scanner 3100 and up to 20 networked Scanner 
2000 series devices. Enron history is included.

• S3100_MAP_TEMPLATE_ENRON_BASE_UNIT. Includes registers for the Scanner 3100 only. Networked Scanner 
2000 series devices are not included. Enron history is included.

• S3100_MAP_TEMPLATE_MODBUS. Includes the same registers as the S3100_MAP_TEMPLATE_ENRON_
DEFAULT database but presents data in a 16-bit format. Enron history is not included.

Note Users who prefer a legacy version of these database templates can access them from the same template direc-
tory for use with the latest ScanMap software. The legacy templates are stored in a zip file (S3100_MAP_TEM-
PLATE_LEGACY.zip) in the default template directory C:\Cameron Data\ScanMap\Configurations. Simply unzip 
the folder to make the database (.smp) files selectable.

Figure 4.1—File menu

By default, new database (.smp) files are saved to the “C:\Cameron Data\ScanMap\Configurations” folder. To change the 
location to which the new database files are saved, see Changing Directories for Database Map and Manual Files, page 
12.

Once a custom database is created, users can open it from the File menu to make modifications or verify register content 
by selecting File>Open Database. Legacy database files can be opened in ScanMap and saved for use with the current 
firmware version. For quick access, the File menu also includes links to the four most recently opened database files.

CAUTION  Do not use File>Open Database to create a database from a preloaded database unless you want 
to permanently change the contents of the preloaded database. Changes made to a database are 
permanent and become effective instantaneously (there is no “Cancel” button to undo changes 
and no prompt to save changes). To create a custom map from a preloaded database, choose 
File>New from Existing instead. 
 
If changes are made to a preloaded protocol map unintentionally, follow the procedures in Restor-
ing a Factory Default Database, page 33 to restore the preloaded protocol map(s).
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Creating a New Database
Creating a new database from scratch allows you to customize the Modbus map.

Note If an existing database contains many of the registers desired, you may save time by opening a copy of the exist-
ing database and modifying it as desired. See Creating a New Database from an Existing Database, page 17 
for details. 

To create a new database from scratch, 

1. Choose File>New Database. The New Database dialog will appear (Figure 4.2).

Figure 4.2—New Database dialog

2. As shown in, enter a unique name for the map title in the “Map Name” field and click Save. The name will appear 
at the top of the main screen, the top of the manual exported from this map, and at the top of any reports generated 
from a Scanner using the map.

3. From the “Firmware Version” dropdown menu, select a different firmware version if the map is being built for use 
with a different firmware version than the default version shown. The New Database dialog will close and a Save 
Database As dialog (Figure 4.3) will appear, populating the name selected in Step 2 as the database filename.

Figure 4.3—Save Database As dialog
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4. Browse to the location to which you want the file stored or leave the default file location and click Save to store the 
database file. 

Note Database files are saved to the “C:\Cameron Data\ScanMap\Configurations” folder by default. 

Firmware Verification
Note ScanMap software versions 1.1.0 or later support Scanner 3100 firmware versions 2.000 and later. ScanMap 

version 1.0.0 supports Scanner 3100 firmware versions 1.100 and 1.103.

If the firmware version used to create the map is not the current firmware version, ScanMap will prompt you to update 
the map to the newer version of firmware, as shown in Figure 4.4. To change the firmware version, 

1. Click the Change Firmware Version button in the upper right corner of the main screen (Figure 4.4) and select the 
appropriate firmware version from Change Firmware Version dialog (Figure 4.5). 

Note If a customized map contains registers that are no longer supported by the selected firmware version, the rows 
containing the unsupported registers will appear in red and an Exceptions Log will be generated when attempting 
to create a new map (.pmap).

Figure 4.4—Firmware Out-of-date note and location of Change Firmware Version button

 
Figure 4.5—Change Firmware Version dialog

2. Click OK. The database will be updated with the new firmware and saved to its original directory, after which you 
will be returned to the main screen.

Creating a New Database from an Existing Database
To use an existing database as a template for a new database, 

1. From the main screen, choose File>New from Existing (Figure 4.1, page 15). The Select Existing Database to 
Copy dialog will appear (Figure 4.6, page 18).

2. Select the database file to be copied and click Open.

3. In the Save Database As dialog (Figure 4.3, page 16), browse to the desired save location,.enter a unique name in 
the “File Name” field and click Save. 

Note Database files are saved to the “C:\Cameron Data\ScanMap\Configurations” folder by default.
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4. Select File>Change Map Name and enter a unique name for the new map. The name will appear at the top of the 
main screen, in the title of the manual created from the map, and in any reports generated from a Scanner using the 
map.

5. Verify the firmware version and change if applicable. See Firmware Verification, page 17 for details.

6. Proceed to configure registers using the instructions in Configuring a Custom Map, page 19.

 
Figure 4.6—Select Existing Database to Copy dialog

7. When the database is verified as complete, proceed with creating a map or manual. See Section 5—Creating and 
Uploading a Modbus Map, page 23 for instructions.

Editing an Existing Database
CAUTION  Before editing an existing database, make certain that it is your intent to permanently change the 

contents. Any changes you make to an existing database will overwrite database content without 
any prompts to save or cancel.  
 
To use an existing database as the starting point for a new database without altering the existing 
database, choose File>New from Existing and save the file with a unique name. See Creating a New 
Database from an Existing Database, page 17 for details. 

To make changes to an existing database,

1. Choose File>Open Database (Figure 4.1, page 15).

Note To open the database file without having ScanMap opened, browse to the database file location and double-click 
on the filename.

2. From the Select Database to Open dialog (Figure 4.7, page 19), browse to the database you wish to open. By de-
fault, the pre-loaded databases are stored in the “C:\Cameron Data\ScanMap\Configurations” folder and user-created 
databases are stored in the “C:\Cameron Data\ScanMap\Maps” folder.
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3. Click Open.

4. Proceed to configure registers using the instructions in Configuring a Custom Map, page 19.

5. When the database is verified as complete, proceed with creating a map or manual. See Section 5—Creating and 
Uploading a Modbus Map, page 23.

 
Figure 4.7—Select Database to Open dialog

Configuring a Custom Map
Important  Once a database is created, the first step in creating a custom map is creating a register group us-

ing the “+” button near the top of the main screen.

ScanMap allows users to create up to 100 register groups per database. To establish register groups for a Modbus map, 
perform the following steps:

1. Click the “+” button to add an unnamed register group to the grid on the left side of the screen (Figure 4.8). 

2. Edit the starting address, group name and register size in the fields provided. If the map you are preparing is for 
an Enron-compliant host, refer to the “Suggested Enron Groups” box. Both 32-bit and 16-bit register sizes are 
supported.

1 2

Figure 4.8—Main screen showing steps for creating register groups
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3. Repeat Steps 1 and 2 until all desired register groups are established.

4. Select and configure registers from each group to be included in the custom map, or, if using a database that was 
creating from an existing database, edit the registers within each group using the steps described below. 

Selecting Registers from Each Group
To select the registers to be included in the custom map, 

1. Click on a group in the grid at the top of the main screen to select (it will automatically be highlighted).

2. Click the Edit Registers (Figure 4.9) button on the left side of the page just below the “Group” grid. The Edit Reg-
isters screen will open (Figure 4.10, page 21).

 
Figure 4.9—Edit Registers button on the main screen

3. In the “Available Registers” section of the screen, browse to the register you want by clicking on individual catego-
ries to expand the selections list or use the “Search” field to find a register by keyword. Click the Find button repeat-
edly to find the next match until there are no more matches.

Note Clicking the Find button begins the search from the highlighted register and searches down. To avoid missing 
your search parameter, highlight the topmost register before searching.

• By default, the “Available Registers” view shows only the main register categories. To view all available 
registers, click the Expand All button, shown on the right in Figure 4.11, page 21. 

• Click the Collapse All button to view only the main register categories, as shown on the left in Figure 4.11, page 
21.
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4. To add a register to the bottom of the “Map Registers” list in the center of the screen, double-click the desired regis-
ter or single-click it and click the right arrow. Alternatively, insert a new register at a specific location by clicking the 
register in the “Map Registers” list to mark the point of insertion, then double-clicking a register from the “Available 
Registers” panel. The new register will be inserted immediately below the register highlighted in the “Map Regis-
ters” section.

Search for 
Register

Edit 
Register 
Name

Add Register 
to Map

Change Units for 
Selected Register

Delete Register 
from Map

Change Register 
Location within Map

Figure 4.10—Edit Registers screen

Figure 4.11—”Available Registers” section of Edit Registers screen, collapsed view (left) and expanded view (right)
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Note To add multiple registers at one time, press and hold the <CTRL> key, click on the registers you want to add, and 
click the Right Arrow to add the selected registers to the “Map Registers” list.

5. Edit the register name or unit using the fields at the right of the screen (Figure 4.10, page 21), if desired. User-
defined register names will be included in the .html manual, but will not appear elsewhere in the web interface.

a. Click in the “User-Defined Register Name” field and enter a unique name for the register, if desired.

b. Click in the “Units” field and select the desired unit of measure from the dropdown list. 

Note For registers that are not associated with units of measure, the “Units” dropdown list will not be displayed.

Important  To make a universal change to unit type (SI Units or US Customary) or to change the unit associ-
ated with a specific measurement category, see Section 3—Configurable Options, page 11 for 
detailed instructions. 

6. Repeat Steps 1 through 5 for each register you want to add to the map.

7. Verify that the selected registers and register order are correct.

a. To change the order in which a register appears in the map, select the register and click the Up and Down ar-
rows to move the item higher or lower in the “Map Registers” list.

b. To delete any register(s) added by mistake, select the register(s) and click the  button.

c. To revert to the default units for all registers within the selected group, click the Default All Units button below 
the “Map Registers” section of the screen. This sets the units to the default settings established in the General 
Options screen.

8. Click OK to save your changes or Cancel to discard all changes and exit to the main screen. 

9. Click on the next register group and repeat the steps above until all registers are defined for the database.

10. When the database is verified as complete, proceed with creating a map and/or manual. See Section 5—Creating and 
Uploading a Modbus Map, page 23.

Changing Register Categories
Most registers are fixed to a specific category. However, some registers have categories that can be changed. For exam-
ple, Analog 1 can be configured to have a default category (as shown in Figure 3.1, page 11), while one register could 
be configured on the fly to output values in a different category.

Figure 4.12—Edit Registers screen showing Analog 1 set to output two categories
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Section 5—Creating and Uploading a Modbus Map
Once all desired changes have been made to a custom database, you are ready to create the custom map for uploading to 
the Scanner 3100. When you create the binary, uneditable map (.pmap) file, you also create the Modbus manual (.html). 
The Modbus manual lists the map registers in an easy-to-share .html file and can be opened with any web browser.

Buttons at the bottom of the main screen (Figure 5.1) give the user the option of creating a map and a manual, or creating 
only a manual.

Creating a Manual Only
A ScanMap manual (.html) is ideal for distribution to others for review and validation before creating a final map for up-
load. To create only a manual file,

1. At the bottom of the main screen, click Create Manual Only. 

Figure 5.1—Create Manual Only and Create Map and Manual buttons
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2. When the Save As dialog (Figure 5.2) appears, enter the desired name in the “File Name” field.

Figure 5.2—Save As dialog when creating a manual only

3. Click Save. The manual will be instantaneously displayed in the computer’s web browser (Figure 5.3, page 25) 
and saved to the “C:\Cameron Data\ScanMap\Maps” folder by default, or in a user-specified directory.

Note Manual files can only be saved in .html format.
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Figure 5.3—Sample Modbus manual

Note Each map begins with a list of selected register groups. A table of archive record units is shown with Enron maps 
that contain Enron-specific registers. The 16-bit Modbus maps do not include a units table. 

Creating a Map and Manual
When the map and manual are created simultaneously, both can be uploaded to the Scanner 3100 web interface and the 
manual can be viewed from within the interface. To create a map and manual,

1. At the bottom of the main screen (Figure 5.1, page 23), click Create Map and Manual.

Note The manual is viewable within the interface only when the Make Manual Viewable in Web Interface checkbox 
is checked on the General Options screen. See General Options Screen, page 9 for more information.
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2. When the Save As dialog (Figure 5.4) appears, enter the desired name in the “File Name” field. This name will be 
used for both the map (.pmap) and manual (.html) files. The map and manual files will be saved to the “C:\Cameron 
Data\ScanMap\Maps” folder unless otherwise specified.

Figure 5.4—Save As dialog when creating a map

3. If the database includes registers that are not supported by the firmware selected, the following warning message (Figure 
5.5) will be displayed, the invalid registers will appear red in the Edit Registers dialog and an Exceptions Log will be cre-
ated and stored in the “Maps” folder. Click OK to proceed with saving the map and manual files.

Figure 5.5—“Invalid registers” warning

4. Click Save. 

Backup Database Files 
When a map (.pmap) file is saved to the C:\Cameron Data\ScanMap\Maps folder, a backup copy of the database (.sbck) file 
used to create the map is saved to the same Maps folder by default. This file exists for the sole purpose of restoring a data-
base to the contents used to create a known manual in the event that the primary database file in the Configurations folder 
that was used to create the map is deleted or is accidentally overwritten.
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The backup file is easily recognized by its filename and .sbck extension. The backup filename contains important informa-
tion that is useful in matching a database file to the manual that was created from it. The .sbck filename includes the following 
information:

• User-specified map name

• Date of map file creation

• Time of map file creation

• Map firmware version

For example, if a map is named “Flow Run 1 Modbus Map,” the backup database filename will be  
Flow Run 1 Modbus Map_[YYYYMMDD]_[HHMM]_[FIRMWARE VERSION].sbck. 

Important  Whereas database files are typically stored in the “Configurations” folder upon creation, the 
backup database file is stored with the map in the “Maps” folder. In the event the database in the 
“Configurations” folder is accidentally changed or deleted after the map is created, the user can 
still access the register configuration used to build the map file by converting the backup file to 
a selectable database file. See Restoring a Custom Database File from a Backup File, page 33 for 
instructions on restoring a database file from a backup file.

Uploading a Map to the Scanner 3100
Custom Modbus maps can be uploaded to the Scanner 3100 using ScanFlash software or the Scanner 3100 web interface.

ScanFlash
 To install ScanFlash software, visit Cameron’s Measurement website at products.slb.com, select Scanner 3100 Series 
Wired and Wireless, and click on the link for the ScanFlash install. A zip file will be downloaded to your laptop or PC. 
To install the utility

1. Unzip/extract the installation folder.

2. Open the unzipped installation folder and run the “setup.exe” file. When the installation is complete, a ScanFlash 
desktop shortcut will appear on the computer desktop (Figure 5.6).

ScanFlash

Figure 5.6—ScanFlash icon

To upload a custom Modbus map

1. Open the ScanFlash utility.

2. Select 3100 from the Model dropdown menu.

3. Enter the IP address used to connect to the desired Scanner 3100 (Figure 5.7, page 28).
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Figure 5.7—ScanFlash interface

4. Select the Modbus map (.pmap) to be uploaded from C:\Cameron Data\ScanMap\Maps (Figure 5.8, page 29).

If you are uploading new Scanner 3100 firmware and you want to upload an custom Modbus map, click Upgrade 
and Upload Customer Modbus Map and browse to the file to be uploaded, as shown in Figure 5.7.

5. Enter the user name and password used to access the Scanner 3100 web interface.

Important  Users must have or Administrator access level to upload a map file to the Scanner 3100. If any 
other user level attempts to do so, the Results Log screen will display an “Insufficient Access 
Level” error message.

6. In the “Verify Connection” section, click Verify. The button will turn blue while the utility attempts to communicate 
with the Scanner.

 • When a connection has been verified, the Scanner’s system information will appear in the Results Log at the bot-
tom of the screen. 

 • If a connection cannot be made, an error message will appear. Check the IP address, the username and the pass-
word and click Verify again.

Important  The firmware version selected for creating the map must match the version of firmware installed in 
the Scanner 3100. If the firmware versions are not the same, the map will not load successfully. To 
select the correct firmware version, see Changing the Firmware Version, page 31.

28

Section 5 ScanMap



Figure 5.8—Select Flash File dialog

7. When a connection with the device is confirmed, click Begin in the “Start Upload” section to begin the upload to the 
Scanner 3100. The Status bar will show the progress of the upload completion.

8. When the upload is complete, ScanFlash will automatically disconnect from the Scanner 3100 and the Results Log 
at the bottom of the screen will display “Successfully Flashed Scanner.” 

Troubleshooting 
If the upload does not complete as expected, communications may have been lost during the upload or the file you were 
attempting to upload was created for use with a different version of firmware than that installed on the Scanner 3100. To 
resolve this issue, 

1. Check for firmware compatibility (see Firmware Verification, page 17). If firmware is compatible, proceed to 
Steps 2 through 5.

2. Click Cancel to abort the upload.

3. Remove power from the Scanner 3100.

4. Restore power to the Scanner 3100.

5. Restart ScanFlash and repeat the upload process.

Scanner 3100 Web Interface
To upload a custom Modbus map using the Scanner 3100 web interface

1. Log into the device using any web browser.

2. Choose the Administration tab at the top of the interface, and click the General dropdown selection. 

3. Click the Installed Files button at the left of the screen to access the Installed User Files page. 

4. Under the heading “Install Protocol Map File,” browse to the desired .pmap file, select it, and click Submit. 

For additional information, see the Scanner 3100 Web Interface manual.
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Section 6—Map/Register Maintenance
Most of the decisions about formatting a custom Modbus map will be made during the creation of the database. Howev-
er, there may be occasions where the user wishes to make a change to a map after a database is created. This section dis-
cusses changes that may be required in maintaining the Scanner 3100 map over time.

Changing the Map Name
When creating a map, the title at the top of the main screen will appear in the title of the manual created from the map 
and in any reports generated from a Scanner using the map. This step is especially useful when creating a new database 
from an existing one to ensure the map and manual created with the new database is uniquely identified. To change the 
title

1. Choose Options>Change Map Name. The Change Map Name dialog (Figure 6.1) will appear.

 
Figure 6.1—Change Map Name dialog

2. Enter the new map name in the field provided.

3. Click OK. The new title should appear at the top of the screen.

Changing the Firmware Version
Once a database is created, a user can modify it for a Scanner device operating on a different firmware version by editing 
the firmware version as follows: 

1. Click on the Change Firmware Version button in the upper right corner of the main screen.

2. Select the firmware version you wish to use from the Change Firmware Version dropdown list, as shown in Figure 
6.2.

Figure 6.2—Change Firmware Version dialog

Important  Any change you make will be saved in the database. If you intend to make changes other than to 
the firmware version, consider creating a new database from an existing one (see Creating a New 
Database from an Existing Database, page 17, for details) before making the firmware version 
change.

Note If a customized map contains registers that are no longer supported by the selected firmware version, the rows 
containing the unsupported registers will appear in red and an Exceptions Log will be generated when attempting 
to create a new map (.pmap).

3. Click OK to return to the main screen.
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Standardizing Units in a Database
By default, the changes made to units and rates from the General Options screen apply only to new registers added to a 
database. To extend these changes to all registers in a database, 

1. Open the database file (.smp) to be changed.

2. Access the General Options screen by choosing Options>General Options.

3. Click the Apply to All Registers checkbox in the “Default Measurement Units Configuration” section of the Gen-
eral Options screen (see Figure 2.3, page 9).

4. Click OK.

Restoring Units to Default Settings
If you made changes to a map’s display units on the Edit Registers screen, but now you want to use the default units you 
established in General Options screen configurations, 

1. Open the database file (.smp) to be changed.

2. Open the Edit Registers screen by clicking the Edit Registers button on the main screen (see Figure 4.9, page 
20).

3. Locate and click the Default All Units button centered below the “Map Registers” section of the screen (Figure 6.3).

4. Click OK.

Figure 6.3—Default All Units button
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Restoring a Custom Database File from a Backup File
Typically the database file used to create a map are stored in the C:\Cameron Data\ScanMap\Configurations folder for use in 
creating new custom maps as needed.  

However, in the event that the database file in the Configurations folder that was used to create the map is deleted or is 
accidentally overwritten, you can restore the database contents using a backup file that is auto-generated each time a map 
is created.

Important  Whereas database files are typically stored in the “Configurations” folder upon creation, the 
backup database file is stored with the map in the “Maps” folder. 

Backup Database Files
When a map (.pmap) file is saved to the C:\Cameron Data\ScanMap\Maps folder, a backup copy of the database (.sbck) file 
used to create the map is saved to the same Maps folder by default.

The backup file is easily recognized by its filename and .sbck extension. The backup filename contains important informa-
tion that is useful in matching a database file to the manual that was created from it. The .sbck filename includes the following 
information:

• User-specified map name

• Date of map file creation

• Time of map file creation

• Map firmware version

For example, if a map is named “Flow Run 1 Modbus Map,” the backup database filename will be  
Flow Run 1 Modbus Map_[YYYYMMDD]_[HHMM]_[FIRMWARE VERSION].sbck.

Database Restoration
To restore a database file using a backup file,

1. Make a copy of the backup (.sbck) file in the Maps folder and paste it into the C:\Cameron Data\ScanMap\Configu-
rations folder.

2. Change the .sbck extension to .smap. If desired, the filename can also be changed at this time. A caution prompt will 
appear, advising that the file may become unusable when the extension is changed. Click “Yes” to confirm your intent to 
change the extension and close the dialog.

3. The .smap file is now selectable from the file menu using the Open Database or New From Existing selection. See Creat-
ing a New Database from an Existing Database, page 17, and Editing an Existing Database, page 18, as required.

Restoring a Factory Default Database
Database changes are permanent and become effective instantaneously (there is no “Cancel” button to undo changes and 
no prompt to save changes). Therefore, users are discouraged from making changes to the preloaded database templates. 
See Creating a New Database from an Existing Database, page 17.

If changes are made to a preloaded database template unintentionally, the user can restore it using a ScanMap backup di-
rectory, as follows.

1. Exit ScanMap and navigate to the “C:\Cameron Data\ScanMap\Configurations” folder.

2. Double-click S3100_MAP_TEMPLATE_BACKUPS.zip to view the contents (Figure 6.4, page 34).

3. Click Extract Files to save a copy of the files in a separate “S3100_MAP_TEMPLATE_BACKUPS” folder. 

4. Open the “S3100_MAP_TEMPLATE_BACKUPS” folder, right-click the protocol map that was overwritten and 
select Copy.
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Figure 6.4—S3100_Map_Template_Backups directory

5. Return to the “C:\Cameron Data\ScanMap\Configurations” folder, right-click anywhere within the folder and select 
Paste. 

6. If prompted to overwrite the existing file, click OK. The default protocol map will be restored.

Important  Do not browse to the “S3100_MAP_TEMPLATE_BACKUPS” folder directly from ScanMap. This will 
change the default path for saving maps. 

Important  ScanMap software installs only one backup file for each preloaded database template. If a backup 
file is accidentally overwritten, the ScanMap software must be uninstalled and reinstalled to re-
store the preloaded factory default database templates. 
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Section 7—Technical Support
For assistance with technical issues, 

1. Choose Help>About from the main screen. The About ScanMap screen will appear (Figure 7.1).

Figure 7.1—About ScanMap screen

2. Click on the Technical Support button to access a phone number or email address for the regional Cameron office 
nearest you (Figure 7.2).

Figure 7.2—Technical Support screen
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WARRANTY - LIMITATION OF LIABILITY:  Seller warrants only title to the products, software, supplies 
and materials and that, except as to software, the same are free from defects in workmanship and 
materials for a period of one (1) year from the date of delivery.  Seller does not warranty that software 
is free from error or that software will run in an uninterrupted fashion.  Seller provides all software “as 
is”.  THERE ARE NO WARRANTIES, EXPRESS OR IMPLIED, OF MERCHANTABILITY, FITNESS 
OR OTHERWISE WHICH EXTEND BEYOND THOSE STATED IN THE IMMEDIATELY PRECED-
ING SENTENCE.  Seller’s liability and Buyer’s exclusive remedy in any case of action (whether in 
contract, tort, breach of warranty or otherwise) arising out of the sale or use of any products, software, 
supplies, or materials is expressly limited to the replacement of such products, software, supplies, 
or materials on their return to Seller or, at Seller’s option, to the allowance to the customer of credit 
for the cost of such items.  In no event shall Seller be liable for special, incidental, indirect, punitive 
or consequential damages.  Seller does not warrant in any way products, software, supplies and 
materials not manufactured by Seller, and such will be sold only with the warranties that are given by 
the manufacturer thereof.  Seller will pass only through to its purchaser of such items the warranty 
granted to it by the manufacturer.
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