
Scanner Data Manager
Software User Manual

Valves & Measurement
 

Manual No. 2350971-01, Rev. 04



Important Information

Terms Used in this Manual

CAUTION		  Indicates actions or procedures which if not performed correctly may lead to incorrect function of 
the instrument or connected equipment.

Important		  Indicates actions or procedures which may affect instrument operation or may lead to an instru-
ment response which is not planned.

Note	 Indicates additional information about specific conditions or circumstances.

Technical Support Contact Information 

TEL: +1.844.226.6327
EMAIL: ms-services@cameron.slb.com
WEB: http://www.cameron.slb.com 

*Mark of Schlumberger.

Other company, product, and service names are the properties of their respective owners.

Copyright © 2017 Schlumberger Limited. All rights reserved.

Manual No. 2350971-01, Rev. 04
November 2017



Table of Contents

Important Information.......................................................................................................................................... 2

Section 1—Getting Started................................................................................................................5
Installation........................................................................................................................................................... 5

Computer Display Resolution....................................................................................................................... 5
Navigating the Software...................................................................................................................................... 5

Viewing Tabular Data.................................................................................................................................... 6
Viewing Trend Logs....................................................................................................................................... 7
Viewing a Snapshot Report.......................................................................................................................... 7
Exporting and Emailing Archive Files............................................................................................................ 7
Printing a Report........................................................................................................................................... 7
Converting Data............................................................................................................................................ 7
Customizing the Interface............................................................................................................................. 7
Changing Trend Views.................................................................................................................................. 8
Changing Logging Level............................................................................................................................... 9

Section 2—Viewing Data Files........................................................................................................11
Default Viewing Settings.................................................................................................................................... 12
Viewing Logs as Tabular Data........................................................................................................................... 12

Sort Order................................................................................................................................................... 13
Data Filtering by Date................................................................................................................................. 13
Data Filtering of Event, Alarm, and User Change Logs.............................................................................. 14

Viewing Logs as Trend Graphs......................................................................................................................... 16
Top Graph................................................................................................................................................... 16
Bottom Graph.............................................................................................................................................. 17
Customizing the Trend Graph View............................................................................................................ 17
Viewing Trends by Record ......................................................................................................................... 20
Viewing Trends by Date/Time .................................................................................................................... 22
Choosing Axes............................................................................................................................................ 24
Adjusting the Data Range........................................................................................................................... 24
Enabling/Disabling Parameter Trend Lines................................................................................................. 25
Analyzing a Single Trend Line.................................................................................................................... 26

Viewing a Snapshot Report............................................................................................................................... 27
Searching the Snapshot Report.................................................................................................................. 28

Section 3—Exporting and Emailing Archive Data.........................................................................31
Exporting Tabular Data...................................................................................................................................... 31

Exporting Data for a Single Log Type......................................................................................................... 32
Exporting Data for Multiple Log Types........................................................................................................ 33

Emailing Tabular Data....................................................................................................................................... 35
Emailing Tabular Data for a Single Log Type.............................................................................................. 35
Emailing Tabular Data for Multiple Log Types............................................................................................. 36
Emailing Data Converted to Flow-Cal or PGAS Formats........................................................................... 38

Emailing an Archive (SDF or SCM) File............................................................................................................ 38
Exporting Trend Data........................................................................................................................................ 40

Section 4—Generating Reports......................................................................................................43
Standard Reports.............................................................................................................................................. 44

Creating a Standard Report for “Current” Tab............................................................................................. 44
Creating a Standard Report for “All” Tabs................................................................................................... 48

Custom Reports................................................................................................................................................ 49
Setting Common Defaults........................................................................................................................... 50

iii

Scanner Data Manager	  Table of Contents



Production Report Templates............................................................................................................................ 52
Adding and Deleting Templates.................................................................................................................. 52

Creating a New Report Template...................................................................................................................... 52
Configuring Columns.................................................................................................................................. 53
Changing Extra Headers and Summary Items........................................................................................... 55
Customizing the Page Layout..................................................................................................................... 56

Viewing and Printing a Custom Report.............................................................................................................. 57
Printing a Legally-Relevant Log........................................................................................................................ 59

Section 5—Converting Data............................................................................................................63
Batch Conversion.............................................................................................................................................. 63

Conversion Options.................................................................................................................................... 63
Flow-Cal Conversion Options..................................................................................................................... 64
PGAS Conversion Options......................................................................................................................... 66

Performing a Batch Conversion........................................................................................................................ 66
Converting a Single File to Flow-Cal or PGAS Format..................................................................................... 67
Emailing Converted Flow-Cal or PGAS Files.................................................................................................... 67

Appendix A—Changing Measurement Units ..............................................................................A-1
Scanner 3100 Units..........................................................................................................................................A-1
Scanner 2x00 Units..........................................................................................................................................A-2

Changing Parameter Displays...................................................................................................................A-2
Changing Default Decimal Display............................................................................................................A-3

Scanner 11xx Units...........................................................................................................................................A-3
Changing History Settings.........................................................................................................................A-3
Changing Units Settings............................................................................................................................A-4

Appendix B—Technical Support...................................................................................................B-1
Help Menu........................................................................................................................................................B-1

Send File to Cameron................................................................................................................................B-1
Technical Contacts.....................................................................................................................................B-1

iv

Table of Contents	 Scanner Data Manager



Section 1—Getting Started
Scanner Data Manager* software allows users to view, print, convert, and export data generated by Cameron’s Scan-
ner* flow computers for quick review in the field or in-depth analysis in the office. The software also contains tools for 
presenting data in a professional customized report. Scanner Data Manager opens the proprietary .SDF and .SCF ar-
chive files created by Cameron software products such as ModWorX* Pro and ScanWin*. Scanner Data Manager sup-
ports Scanner models 3100, 2200, 2100, 2000, 1141, 1140, and 1131.

Installation
Verify that the computer on which the software is being installed meets the following requirements:

Table 1.1—Installation Requirements
System Parameter Requirement(s)

Operating System Windows 7 or later

Computer/Processor 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor
Memory 1 GB RAM (32-bit) or 2 GB RAM (64-bit)
Hard Disk Space 100 MB for program files, adequate space for data files
Display DirectX 9 graphics device with WDDM 1.0 or later driver

Important		  Before attempting to install Scanner Data Manager software, ensure that you have local adminis-
trator rights to the computer on which the software is to be installed. If the installation is blocked, 
contact your Information Technology department for assistance. 

To install the software, perform the following steps: 

1.	 Visit Cameron’s Measurement website at http://www.cameron.slb.com/flowcomputers, select Scanner Model 3100 
Flow Computer, and click on the link for the Scanner Data Manager install. A zip file will be downloaded to your 
laptop or PC.

2.	 Unzip the installation folder.

3.	 Open the unzipped installation folder and click the “setup.exe” file to begin installation.

When the installation is complete, a Scanner Data Manager desktop shortcut will appear on the desktop (Figure 1.1).

Scanner 
Data 

Manager

Figure 1.1—Scanner Data Manager desktop shortcut

Computer Display Resolution
For best viewing, configure your computer display with a resolution of 1024 × 768 or higher. If a lower resolution is 
used, portions of the Scanner Data Manager interface may be hidden from view.

Navigating the Software
This section provides an overview of the Scanner Data Manager software tools and screens. For step-by-step instruc-
tions, see Section 2—Viewing Data Files, page 11, through Section 5—Converting Data, page 63.
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Viewing Tabular Data
A tabular display allows the user to quickly locate and review specific data. Data are grouped logically into measurement 
data and log types, such as Interval History, Daily History, Triggered History, Snapshot, Alarms, Events, Configuration, 
Calibrations, User Changes and Log. Within these groupings, log data are displayed chronologically. Log data can be 
filtered or sorted by time and date ranges and printed. Event, alarm, and user change logs can be filtered by data such as 
flowrun, type of event or alarm, user change, and user login, as well as by month/day or date range. See Data Filtering by 
Date, page 13, and Data Filtering of Event, Alarm, and User Change Logs, page 14, for details.

Note	 The User Changes tab, which shows calibrations and user-initiated changes, only appears when viewing archive 
files for Scanner 11xx devices and Scanner 3100 devices. User changes appear on the Events tabs for Scanner 
2x00 devices.

Note	 Data types represented by tabs along the top of the screen will vary with the device used to generate the data 
and the data types included in a download.

The Log tab allows the user to view data parsing details and search for user-specified information.

When a file contains log data for multiple flowruns and/or slave devices†, the data are grouped by flowrun or slave de-
vice in tabs at the bottom of the screen, as shown in Figure 1.2.

‡Note	 Only Scanner 3100 archive files contain slave device data (for up to 20 slave devices) in addition to two integral 
flowruns.

Flow runs 
and slave 

devices are 
listed in 

tabs.

Click here to 
view or hide 
additional 

information.

Status 
flags in 

this 
column 

are 
defined in 

blue 
below.

Figure 1.2—Multiple flowrun tabs
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Click on the double-chevron icon (identified in Figure 1.2, page 6) on the top far right of the data screen to view de-
vice-specific data, such as device name, device location, firmware version, download date and time, etc. Click again to 
hide the information and display more data.

The number of visible records is displayed for Interval History, Daily History, Alarms, and Events. The display is located 
under “Sort Order” in the area immediately below the tabs, as shown in Figure 1.2, page 6. Visible records is not an 
indication of the total records downloaded. The “visible records” count reflects only those records selected for display 
and is dependent on the filters applied.

Viewing Trend Logs
Users can also view measurement data in a full-color graph or “trend” view. Users can zoom in and out, scroll data, and 
control the range of the data to be displayed. For further explanation, see Viewing Logs as Trend Graphs, page 16.

Viewing a Snapshot Report
A snapshot report, available on the Snapshot tab, captures flowrun and calculated data for a specified point in time for au-
diting purposes. Users can view, export, or email a snapshot report to others. See Viewing a Snapshot Report, page 27, 
for details.

Exporting and Emailing Archive Files
Tabular data can be exported to Excel (XLSX), comma-delimited (CSV), Internet (HTML), portable data file (PDF), and 
document/rich-text (RTF) formats. Trend data can also be exported as a non-editable image to PDF, .RTF, BMP,  JPG, 
and GIF formats. If the exported tabular data is to be emailed, Scanner Data Manager will automatically attach export 
files to an email file, ready for addressing to a recipient. See Exporting Tabular Data, page 31, Emailing Tabular Data, 
page 35, and Exporting Trend Data, page 40, for details.

Printing a Report
Scanner Data Manager reporting capabilities are highly customizable. Users can print any individual log type as a simple 
spreadsheet or construct a detailed professional report using the embedded customization tools. See Section 4—Generat-
ing Reports, page 43, for details.

Converting Data
Scanner Data Manager allows users to convert Scanner archive files into third-party PGAS and Flow-Cal software for-
mats. See Section 5—Converting Data, page 63 for details.

Customizing the Interface
Changing Viewing and Export Settings
The Scanner Data Manager interface can be customized to suit individual preferences and save users time in performing 
repetitive tasks. For a complete list of configurable viewing options, click Options>Viewing Options.

From this dialog, users can perform the following changes to general settings (Figure 1.3, page 8):

•• Change the location where archive files are stored.

•• Change export options, such as configuring .csv file exports to use quotes as a delimiter and configuring export files 
to automatically open when they are saved.

•• Change Scanner 11xx and Scanner 2x00 default unit type to US Customary Units or SI Units.

•• Change the timestamp convention. By default, timestamps mark the end date/time for each record, which is a known 
value generated by the Scanner. When the history timestamps setting is changed to “Calculated Begin Date/Time,” 
timestamps will mark the beginning date/time for each record, which is calculated in accordance with the previous 
record or interval period, and the column heading will change from “Timestamp” to “Begin Timestamp.”

•• Change the number of calibrations/verifications presented in a report and the sort order used to present the data 
(Only available when viewing Scanner 3x00-created data files.)
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Figure 1.3—Viewing Options screen, General Settings dialog

Changing Measurement Units
To change unit settings or decimal values, click Options>Viewing Options and click the Scanner device in use in the 
menu at the left side of the dialog. Settings vary with Scanner devices. Examples of each set of device settings are pro-
vided in Appendix A—Changing Measurement Units, page A-1.

Changing Trend Views
The trend view (Figure 1.4, page 9) shows the file data as a trend graph, rather than a table. This provides you with a 
powerful presentation tool. The trend log can be used with default settings or customized from the Trending Options dia-
log. For further information, see Customizing the Trend Graph View, page 17.
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Figure 1.4—Log Trends View

Changing Logging Level
The logging level is the level of detail reported while the archive file (SDF) is being parsed and applies to data conver-
sion as well as viewing and reporting functions. The default setting “Above+Basic Conversion” includes all errors, warn-
ings, a summary, and basic conversion information, and is recommended for most users.

Note	 If there are errors, a log file is created and stored at C:\Cameron Data\SDM\Logs.

To change the logging level, choose Options>Logging Level (Figure 1.5) and select a logging level.

Important	 	 Increasing the logging level increases the time required to open the archive file. Therefore, 
the level should be changed only when necessary and should be changed back to the default 
level (Above+Basic Conversion) before exiting the program. “Above+Detailed Tracking” and 
“Above+Internal Details” logging levels are for troubleshooting only and should only be used by 
experienced technicians.

Figure 1.5—Options>Logging Level>logging level selections
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“Only Errors” and “Above+Warnings/Summary” are basic logs used to track errors and warnings without logging other 
archive data from the flow computer data file. “Above+Conversion Details” provides additional information regarding 
conversion calculations.

Changing Logging Levels On-the-Fly
To shorten data parsing time or to change the level of detail in the parsed log, the logging level can be changed on-the-fly 
during data parsing using the following steps:

1.	 Click the Pause button (Figure 1.6) on the Log tab to freeze the current parsing log. 

Note	 The Pause button only appears during data parsing. Once the parsing log has been paused, the “Pause” label 
changes to “Continue.”

Figure 1.6—Pause button (Log tab)

2.	 Choose Options>Logging Level and select the new logging level from the menu.

3.	 Click the Continue button to resume parsing. 

Note	 Only unparsed data will be parsed using the new logging level. To parse the entire file using the new logging 
level, you must close and reopen the archive file.
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Section 2—Viewing Data Files
Scanner Data Manager can be used to view any SDF or SCM files download from a Scanner flow computer. To open a 
file, select File>Open (Figure 2.1) and navigate to the file’s location. The four most-recently accessed files are listed at 
the bottom of the File menu for quick access.

Figure 2.1—File menu 

File contents can be previewed by selecting the file name in the Open Archive dialog (Figure 2.2).

Figure 2.2—Open Archive dialog showing file contents on the right of the screen

The software will parse the data records and display the log in the main screen. The presentation of the archive data will 
vary, depending on the Scanner flow computer model in use and the type of data downloaded.

Multiple files can be open at a time. Each opened file will appear as a separate tab at the top of the tabular view (Figure 
2.3, page 12). To exit data files, choose Close to exit a single file or Close All Files to close all open files simultane-
ously (Figure 2.1).
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Default Viewing Settings
Upon installation, Scanner Data Manager will function in accordance with the following default settings:

•• When the user selects File>Open to select an archive file (SDF or SCM), Scanner Data Manager displays the con-
tents of the “C:\Cameron Data” directory.

•• The log type included in the data export is based on the tab selected at the time.

Note	 When exporting data to Flow-Cal or PGAS format, all log types are included in the exported file.

•• Tabular data files are exported to the file format selected from the Export Data dropdown menu. 

•• The log trend view displays logs “By Records” by default. 

•• The interval trend view displays 24 hourly records, and the daily trend view displays 30 records by default. 

Viewing Logs as Tabular Data
The poll date, Scanner firmware version, and filepath for the archive file are published at the top of the screen. The vari-
ous log types (Hourly or Interval History, Daily History, Snapshot, Alarms, Events, etc.) and device settings (Configura-
tion, Calibrations, etc.) are identified in tabs across the top of the screen (Figure 2.3). If a download file contains data for 
more than one flowrun and/or data for slave devices, data will be grouped by flowrun and displayed in separate tabs at 
the bottom of the screen. 

Note	 Scanner 3100 archive files may contain up to 20 slave devices in addition to two integral flowruns.

Flow Runs and 
Slave Devices* 

Displayed 
in Separate Tabs

(*Only Scanner 3100 
archive data 

may include slave 
devices.)

Logs Displayed by Data Type

Each File Opens in a Separate Tab

Change to Trend View

Figure 2.3—Main screen
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Sort Order
By default, data logs will appear in the order in which they are downloaded, top to bottom. However, the user can sort 
data by date/time stamp or record number by changing the selection in the Sort Order dropdown menu (Figure 2.4). 
Each sort order selection is specific to the log type (tab) selected when the sort order is designated.

Figure 2.4—Sorting and data filtering functions

Data Filtering by Date
Log data is easily filtered by checking the “Filter” area and selecting one of the following filtering options, as shown in 
Figure 2.4:

•• Filter by Month/Day—A dropdown menu will list all dates (by month and by day) for which data is stored. The user 
can select multiple dates or months by clicking in the checkbox next to each desired selection.

•• Filter by Date Range—To initiate a filter, click the dropdown arrow next to the “Start Date/End Date” field to dis-
play a calendar dialog, select the desired start and end date/time, and click OK. 

Note	 When timestamps are configured to mark the end date/time (default setting) and data is filtered by month, the 
first day of the month following the “filter month” is automatically included in the filter range. This is because data 
stored on the last day of the month is downloaded at the contract hour of the following day. For example, when a 
user filters data from July, the download from August 1 is included. This download includes data stored during the 
24 hours between the July 31 contract hour and the August 1 contract hour. 
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Data Filtering of Event, Alarm, and User Change Logs
Event, alarm, and user change logs can be filtered by columnar data such as flowrun, type of event, alarm, or user 
change, and login ID, as well as by the standard month/day or date range filters. 

Events can also be filtered by “Group” or “Key.” Group is the type of parameter associated with the event, and Key spec-
ifies the exact parameter associated with the event (which is required when the device supports multiple configurations 
within a function (for example, a Group selection of Digital Output and a Key selection of 2 will cause the spreadsheet to 
filter data for Digital Output 2). 

Note	 Columns that can be filtered have a gray down arrow to the right of the column heading (Figure 2.5).

To filter by column,

1.	 Click on the appropriate tab (event, alarm, or user changes).

2.	 Click on the gray down arrow to the right of the column heading.

3.	 Select the desired filter type from the dropdown menu, as shown in Figure 2.5. The data will be organized by the 
filter type selected.

Click on the 
dropdown arrow 
to the right of the 
column heading and 
select a filter from 
the dropdown menu.

Figure 2.5—Event tab showing dropdown menu

To remove alarm, event, and user change data filters, click the Remove All Filters button, which is located near the top 
of the screen when the Events, Alarms, or User Changes tabs are selected (see Figure 2.6, page 15).
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Figure 2.6—Remove All Filters button

Custom Filtering (Advanced Users)
In addition to the columnar filter checkboxes, users can create a Custom filter to filter data based on specific criteria with-
in a cell. To add a custom filter, 

1.	 Click the appropriate tab (event, alarm, or user changes).

2.	 Click the gray down arrow to the right of the column heading and select (Custom…) from the dropdown list. The 
Custom Filter dialog opens (Figure 2.7).

  
Figure 2.7—Custom Filter dialog
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3.	 In the first selection field, click the dropdown arrow and select your criteria. In Figure 2.7, the criteria for the selec-
tion field on the right is “equals.” In the selection field to the right, enter a type, a value, or text. Note the special 
characters listed at the bottom of the dialog that can be used as “wild cards” to represent any characters or numbers.

4.	 To add a second criterion, click on the and or or button and enter a new criterion and the associated type, value, or 
text in the second row of dropdown menus.

5.	 Click OK to apply the filter.

6.	 To clear the columnar filter without removing a date filter, click the gray down arrow to the right of the column 
heading and select (All).

7.	 To remove all filters, date filter included, click the Remove All Filters button (see Figure 2.6).

Viewing Logs as Trend Graphs
Measurement data trends can be viewed by record number (recommended for continuous logging) or by date/time (rec-
ommended for logs with gaps in data) from the Interval, Daily Logs, Triggered or Data Logger tabs. The trend view pres-
ents the downloaded logs in two graphs (Figure 2.8)—a top graph showing the entire contents of the downloaded log and 
a bottom graph showing a user-selected segment of the log.

3 Optional Y Axes

Top G
raph

B
ottom

 G
raph

Figure 2.8—Log trend view

Top Graph
The top graph provides a high-level view of all data in a log. Click anywhere in the top graph to select the range of re-
cords to be magnified in the large graph display at the bottom of the screen. 
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Note 	 If the records in a log are too numerous to be displayed in the bottom graph, a gray rectangle will appear on 
either side of the top graph. Click and drag the gray rectangle to move the graph and bring hidden records into 
view. 

Bottom Graph
The bottom graph allows a user to view records in detail. Screen controls allow a user to view multiple parameters on 
one graph or isolate selected parameters for viewing. Up to four Y axes can be displayed, maximizing the information 
available in a single view.

To view a different data range 

•• Use the scroll bar beneath the graph to shift the graph to the left or right. 

•• When viewing a trend by record number, advance the graph one record at a time using the right and left arrow but-
tons on the computer keypad or by clicking on the right or left arrow in the scroll bar beneath the graph. 

•• Click the Zoom Out Time Axis button to view more data or Zoom In Time Axis to view data in greater detail.

Customizing the Trend Graph View
To customize the trend graph view, choose Options>Trending Options. The General Trending Options dialog will ap-
pear. From the Trending Options interface, you can choose how trend data is displayed. The options are divided into one 
general category and three Scanner-specific categories, as shown in the left column of Figure 2.9.

General Trending Options
The General Trending Options dialog (Figure 2.9) allows users to customize the settings that will serve as a template for 
all Scanner trend views.

Establish axis preferences 
and add up to three Y axes.

Select trend view and set 
up initial data ranges.

Select the trend line color 
for each parameter.

Figure 2.9—General Trending Options dialog

From this dialog, the user can perform the following tasks:
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•• Select the criteria used to trend data (by record or by date/time, the default).

–– When trending by record, ranges must be even numbers from 2 to 100.

–– When trending by date/time, choose the number of days in the range (0 to 100). 

Note	 Selecting date/time may cause data to load more slowly and the number of record values will not be displayed on 
date/time trend graphs.

•• By default, the left Y axis follows the parameter selection. However, the “Default Axis Settings” allow you to 
configure the right axes to represent a unit category (volume, mass, temperature) or a parameter. Categories can be 
selected selected for up to three right axes in the General Trending Options dialog. 

•• Set up to three additional right Y axes, which appear as inner right axis, middle right axis, and outer right axis se-
quentially. If the inner right axis is changed to “Unused,” all three extra axes will be removed.

Note	 The variable represented by the left Y axis is determined by the active parameter selection, which is highlighted 
in blue. When selecting other axes to display, verify that the parameter selected appears in the data file and has 
a value greater than zero.

•• Select trend colors, if desired. Trend colors will be applied to parameters in the order they appear, and will be re-
peated as required, depending on the number of items in the archive file.

Note	 When selecting trend colors, keep in mind that the screen displays logs on a black background. The printed 
background will be white. If trends will be printed, select colors that will be visible both on screen and in printed 
graphs.

Scanner 3x00 and 2x00 Trend Settings
The model-specific Scanner settings in the left-most section of the Trending Options screen allow users to make addi-
tional choices about how trend data for a specific model is presented. Click the Scanner model in use.

•• Select the parameters to appear on the trend graph (Figure 2.10, page 19).

•• Set the trend graph default units to SI Units or US Customary.

•• Customize the data ranges and/or units associated with select unit categories.

•• Customize axis settings (override general axis settings).

18

Section 2	 Scanner Data Manager



Click in the 
Category 

Settings field 
to toggle the 
display units 

on or off, 
establish 

minimum and 
maximum 

units and the 
type of units 
in the range. 

Apply default units.

Select axis overrides 
for the inner, middle, 
and outer right axes.

Figure 2.10—Scanner 3x00 and 2x00 Trending Options dialog
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Scanner 11xx Trend Settings
Trend customization options vary with Scanner models. From the leftmost section of the Trending Options screen, click 
Scanner 11xx to change trend settings, such as

•• Select the parameters to appear on the trend graph (Figure 2.11).

•• Override trend colors.

•• Customize the data ranges and/or units associated with select unit categories.

•• Customize axis settings (override general axis settings).

Select axis overrides 
for the inner, middle, 
and outer right axes.

Toggle the display on and off, override color settings, 
minimum and maximum range and display units.

Figure 2.11—Scanner 11xx Trending Options dialog

20

Section 2	 Scanner Data Manager



Viewing Trends by Record 
By default, trends are displayed by record number, which is ideal for continuous logging. To view log trends by record, 
click the By Records option in the “Trending” section on the left of the main screen (Figure 2.12), then click the View 
Trends button.

Figure 2.12—View Trends ”By Records” option

The record values will be plotted in trend lines, as shown in Figure 2.13, page 22. 

Note the dotted vertical white line in the bottom graph. This Record Index line remains in a fixed location, and marks the 
record highlighted at left. The value range for the highlighted parameter is displayed on the left axis.

In Figure 2.13, page 22, the Record Index line intersects the trend graph at Log Record Number 4879. The log num-
ber, timestamp, and individual parameter values in that log are displayed in the table at the left of the screen. These num-
bers and values are automatically updated when the data is scrolled using the scrollbar at the bottom of the screen.
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Record Index

Figure 2.13—Record Index marker for viewing trends by record

For information on viewing data values for a specific parameter, see Analyzing a Single Trend Line, page 26.

Viewing Trends by Date/Time 
For logs that include gaps in flow, users may prefer to view trends by date/time by blocks of time rather than by record 
numbers, since gaps may be difficult to identify when viewing by records. 

Note	 Viewing by date/time may result in longer load times for displaying the graph and is only recommended for view-
ing triggered logs or other logs in which a time gap in logging is expected.

To view log trends by date/time, click the By Date/Time option in the “Trending” section on the left of the screen (Fig-
ure 2.14, page 23), then click the View Trends button. 

The date/time values will be plotted in trend lines as shown in Figure 2.15, page 23. 
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Figure 2.14—Log trends select “by Date/Time”

X axis displays date and 
time (determined by 
interval selection) when 
viewing log trend by 
date/time.

Figure 2.15—Log trends displayed by date/time
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Note	 When viewing trends by date/time, the timestamp and log record number fields are not populated in the param-
eters table and the record values do not appear during scrolling. Instead, date and time intervals appear along 
the X axis near the bottom of the screen.

To view data values, select a parameter in the table and click anywhere in the trend graph. A white dotted circle will ap-
pear on the selected trend line and a text box attached to the cursor will display the data value and record date/time for 
the selected data point. Move the cursor over the trend graph to see the values change as the cursor locks on to various 
data points.

For more information on viewing data values for a specific parameter, see Analyzing a Single Trend Line, page 26.

Choosing Axes
Up to four axes may be used to track data values for parameters or categories. See Viewing Logs as Trend Graphs, page 
16 for more information. The left axis is fixed and reflects the active selected parameter. Up to three axes for tracking 
other parameters or unit categories are optionally available on the right side of the trend view. 

To add right axes, click the “Inner Right Axis,” “Middle Right Axis” and “Outer Right Axis” dropdown menus, respec-
tively, and select the parameter or category to be assigned to each. If you select a parameter/category that is unavailable, 
the following message will appear:

Figure 2.16—Y axis warning

Adjusting the Data Range
The trend view display contains a number of controls for customizing the display. Adjust the range of data in view using 
one of the following methods.

Dates and Times
Click on Set Time Axis Range and enter a Range Start date and time and a Range End date and time using the calendars 
provided (see Figure 2.17). For daily logs, enter start and end dates only (no times).

Figure 2.17—Select Date and Time Range dialog 

Enlarge or narrow the time axis by clicking Zoom Out Time Axis or Zoom In Time Axis (Figure 2.15, page 23).
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Data Values
The range of values shown on a Y axis is determined by the data values in the archive file. By default, the Y-axis scale is 
set to show all data values, from lowest to highest value in the record. If the archive file contains irregular data that re-
sults in an abnormal range scale, adjust the Y axis scale using the following steps: 

1.	 Right-click on the tick marks to the right of the Y axis scale values. The Axis Settings dialog will appear (Figure 
2.18).

2.	 Enter the desired maximum and minimum values in the fields provided.

3.	 If desired, change the major increments displayed along the Y axis. This value should be less than the difference 
between the maximum and minimum values established in Step 2. Otherwise, the major increments and axis hash 
marks will no longer be visible on the screen. 

4.	 Click OK to apply the settings to the trend view.
To restore the scale to the actual maximum and minimum values in the archive file, click the Auto Calculate 
checkbox(es) and click OK.

Right-click
on hash marks

Figure 2.18—Accessing the Axis Settings dialog

Enabling/Disabling Parameter Trend Lines
By default, all archive parameters are displayed in the parameter table and in the trend log. Values are displayed only for 
the parameter selected at any given time. To change the parameters displayed in the trend log, select a different param-
eter trend line or enables/disables parameter trend lines following the instructions below:

Click the parameter to be viewed in the graph (Figure 2.19, page 26). The parameter is highlighted in blue, its corre-
sponding trend line is bolded within the graph and markers indicating record locations within the trend line appear. The 
yellow light bulb icon indicates that the parameter trend line is enabled for display.
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Selected parameter 
highlighted in blue

Yellow lightbulb 
= enabled for 

display

Blue lightbulb 
= not currently 

displayed

Figure 2.19—Parameter (by record) table 

Note	 Turning off the light bulb of a parameter that is highlighted in the table will cause the trend line and the Y axis to 
disappear, but the parameter name remains on screen in grayed text. Click the grayed out parameter to restore 
the trend view and the Y axis.

•• To view individual data point values, click the bolded line and move the cursor over the data points. The selected 
parameter name and configured unit are displayed at the top of the graph, and the graph scale adjusts to frame the 
values of the selected parameter. 

•• To disable all parameter trend lines except the one that is selected (highlighted), click the Disable All button.

•• To enable all parameter trend lines, click the Enable All button.

•• To hide a parameter trend line, click on the yellow light bulb icon next to the parameter to be hidden. The light bulb 
icon will change from yellow to blue, and the trend line will disappear from the graph. The parameter name will 
remain at the top of the graph until another parameter is selected for display.

•• To display a hidden parameter trend line, click on the blue (disabled) light bulb icon. The icon will change to yellow, 
and the trend line will appear in the graph. 

Analyzing a Single Trend Line
A user can examine records along a single trend line by clicking on a parameter in the left table. The parameter selection 
will appear highlighted in the table, and the name of the parameter will appear in the corner of the graph (Figure 2.20, 
page 27). 

1.	 Click on the trend line in the Trend window and observe the dotted white cursor on the trend line. Move the cursor 
along the parameter trend line and observe the changing values in the box linked to the cursor. The cursor latches 
onto each data point (record) it encounters, and the associated date and time stamp and recorded value are automati-
cally displayed. This feature assists the user in determining the values for a single trend within the range without 
scrolling. 

2.	 When viewing by record, use the scroll bar below the bottom graph to move the graph across the vertical Record 
Index line. The values of each data point that intersects the Record Index line will appear in the table to the left of 
the trend log.

Note	 When viewing trends by date/time, the timestamp and log record number do not appear in the parameters table 
and the record values do not appear during scrolling. However, clicking on the trend line and moving the cursor 
over the data points (records) will display the date, time and value of when the record was archived.
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Figure 2.20—Log Trends view, single parameter shown

Only the trend line for the parameter that is highlighted in the table can be examined in this way. The cursor will not 
latch onto data points along any other trend line. To view the values associated with a different parameter, select the de-
sired parameter in the table or click on a different trend line.

Viewing a Snapshot Report
The Snapshot report (Figure 2.21, page 28), like the Configuration report, allows a user to view and search flowrun 
and turbine input data, configuration values, sensor input readings and system data for a specific point in time. The report 
can be exported and e-mailed to a technician for diagnostic help or to another user for data validation. 

Snapshot reports are automatically generated and included in downloads from the Scanner 3100 flow computer. Snapshot 
reports are optionally available for download in Scanner 2x00 models. If a snapshot report is not included in a download, 
the Snapshot tab will not appear in the Scanner Data Manager interface.

To view a snapshot report, simply click the Snapshot tab. Use the scrollbar along the right edge of the screen to navigate 
up and down in the report.
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Figure 2.21—Snapshot report

Searching the Snapshot Report
To search within a Snapshot report,

1.	 Click in the search field (Figure 2.22, page 29) and enter the search word or phrase.

2.	 Click Find. The search will identify where the search word or phrase appears.

3.	 Repeat Steps 1 and 2 to search for another word or phrase. 

Note	 The search field will retain your searches until you close the Snapshot report. To repeat a search, click on the 
down arrow at the far right of the search field and select the term from the dropdown list.
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Figure 2.22—Snapshot report after search

4.	 Click Clear to return to the full Snapshot report.

Note	 The Clear button displays the full Snapshot report without deleting search parameters from the dropdown field.

5.	 Exit the Snapshot report to clear the search parameters list.
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Section 3—Exporting and Emailing Archive Data
Scanner Data Manager users can export tabular (spreadsheet) data, a snapshot or configuration report, or trend (graph) 
data in common text or image formats for sharing with others (see Exporting Tabular Data, page 31 or Exporting 
Trend Data, page 40). Users who wish to email tabular data or snapshot exports can process the export and the email 
in one step (see Emailing Tabular Data, page 35). All exported data appears exactly as it does onscreen. For example, 
if the user changes the order in which columns appear onscreen, this change will also be applied to the exported archive 
file(s).

The type of data stored in an export file is identifiable by the letters at the end of the filename (unless the user overwrites 
the filename), as shown in .

Table 3.1—Log Type Indicators in Filenames
Log Type Log Type Indicator

Daily History‡ _D

Hourly (Interval) History‡ _H

Calibration Report _L

Configuration Report _C

Flowrun Configuration† _F

Slave Configuration (3100 only) _F

Event Logs _E

Alarm Logs _A

User Change Logs _U

Triggered History‡ (3100 only) _T

Data Logger History† _T

Data Logger Configuration† _G

ScanPLC Logs† _P

Exceptions Report† _X

Snapshot Report _S

† Created only by Scanner 11xx flow computers.
‡ Trend view export filenames contain a two-character suffix consisting of “T”  
   and the log type indicator Example: _TH (hourly trend).

Exporting Tabular Data
Tabular data can be exported in three formats

•• Single log type  (Exporting Data for a Single Log Type, page 32)

•• Multiple log type (Exporting Data for Multiple Log Types, page 33)

•• File format conversion (all log types included) (Section 5—Converting Data, page 63)

The Export Data button and dropdown menu (Figure 3.1, page 32) act as the gateway for all exporting functions.  
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Figure 3.1—Export Data button and dropdown menu

Exporting Data for a Single Log Type
To export data for a single log type or report type

1.	 Select the tab for the log type/report type to be exported. 

2.	 If exporting daily or interval history, note the tab(s) at the bottom of the screen. Archive files created by a Scanner 
3100 may contain multiple flowrun/slave device tabs, and archive files created by Scanner 1x00 devices may contain 
multiple flowrun tabs. Select the flowrun for which you want to export data. Each export of measurement data will 
contain only data for the flowrun tab selected at the time of export. 

3.	 Click on the Export Data button in the left column of the screen and choose Export Selected from the dropdown 
menu (Figure 3.1).

4.	 Note the filepath (Figure 3.2, page 33) and change if necessary. By default, export files are saved to the “C:\Cam-
eron Data\SDM\Exports” directory on the user’s hard drive.

Note	 Saving files to a directory other than the default will make the new directory the default. 

5.	 Rename the file, if desired. By default, the filename includes the flow computer model, the type of download, the 
flowrun number, and a log type indicator (for example, S3100_Local_1_H.xlsx).
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Default filepath

Model & Download Type Flowrun/Slave Device & Log Type

Figure 3.2—Export [Log Type} Data screen

6.	 Click SAVE to export the data.

Exporting Data for Multiple Log Types
To export multiple log and report types simultaneously

1.	 Click on the Export Data button in the left column of the screen and select Export to... from the dropdown menu 
(Figure 3.1, page 32).

2.	 Select the desired file format, log types and reports from the options (Figure 3.3, page 34).

Note	 The Export Files dialog contains selection boxes for only those log types and report types contained in the 
archive file. For example, if no daily log data was downloaded to the archive file, “Daily History (_D)” will not ap-
pear.

3.	 Note the “File Save Directory” location and change if desired. By default, export files are saved to the “C:\Cameron 
Data\SDM\Exports” directory on the user’s hard drive.
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Figure 3.3—Export Files dialog

4.	 Note the entry in the “File Save Prefix” field and change if desired. The prefix will become the first part of the export 
file name. By default, this prefix includes Scanner model and download type.

5.	 Click OK to export the data.
Each log type or report will be saved as a separate file. The export filename will include the File Save Prefix (if present), 
the flowrun number, and the log type indicator, which is based on the user’s selection(s) in the Export Files dialog. Ex-
ample: S3100_Local_1_H_xlsx.

Exporting Data Converted to Flow-Cal or PGAS Formats
To export the contents of the archive file to a third-party Flow-Cal (.cfx) or PGAS (.ana/.evt/.vol) format:

1.	 See Section 5—Converting Data, page 63, for information on changing conversion settings. This may be espe-
cially useful if gaps in the data are expected. 

2.	 Click on the Export Data button in the left column of the screen and click the desired Export All as... selection 
from the dropdown menu (Figure 3.1, page 32). 

3.	 Note the filepath (Figure 3.3) and change if necessary. By default, export files are saved to the “C:\Cameron Data\
SDM\Exports” directory on the user’s hard drive.

4.	 Rename the file, if desired. By default, the filename includes the flow computer model and the download type (for 
example, S3100_Local.ana).

34

Section 3	 Scanner Data Manager



Emailing Tabular Data
Scanner Data Manager makes sharing data easy by allowing users to export and email data in a single step. To email tab-
ular data:

5.	 Click on the Email Data button in the left column of the screen to view export format selections.

Figure 3.4—Email Data button and dropdown menu

6.	 From the dropdown selections, you can email three different types of exported tabular data: 

•• Single log type (Emailing Tabular Data for a Single Log Type)

•• Multiple log type (Emailing Tabular Data for Multiple Log Types, page 36)

•• File format conversion (all log types) (Section 5—Converting Data, page 63)

Emailing Tabular Data for a Single Log Type
To export and email tabular data for a single log type or report,

1.	 Select the tab (Figure 2.3, page 12) for the log type to be exported and emailed. 

Note 	 The tab(s) at the bottom of the screen are archive files created by a Scanner 3x00 or 11xx Series computer and 
may contain multiple flowrun tabs. Only Scanner 3x00 archive datafiles may contain data for up to 20 slave de-
vices. Select the flowrun (or slave device) for which you want to export data. Each export of measurement data 
will contain only data for the flowrun (or slave device) tab selected at the time of export. 

2.	 Click on the Email Data button in the left column of the screen (Figure 3.4) and click the desired Email [log type] 
file selection from the dropdown list. The Export [Log Type] Data to... dialog (Figure 3.2, page 33) will appear.

3.	 Note the filepath and change if desired. By default, export files are saved to the “C:\Cameron Data\SDM\Exports” 
directory on the user’s hard drive.

4.	 Note the filename and change if desired. By default, the filename includes the flow computer model, the type of 
download, the flowrun number, and a log type indicator (for example, S3100_Local_1_H.xlsx).

5.	 Click Save to export the data. Scanner Data Manager will automatically open an email window on your computer, 
attach the export file, and embed a brief description of the file in the body of the email (Figure 3.5, page 36).
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Figure 3.5—Automated email for single log file

Emailing Tabular Data for Multiple Log Types
To export and email multiple log types and reports simultaneously

1.	 Select Email Selected from the Email Data dropdown menu and select the desired file format and all desired logs/
reports from the options provided (Figure 3.6, page 37).

Note	 The Email Files dialog contains selection boxes for only those log types and report types contained in the archive 
file. For example, if no daily log data was downloaded to the archive file, “Daily History (_D) will not appear. 

2.	 Note the “File Save Directory” location and change if desired. By default, files are saved to the “C:\Cameron Data\
SDM\Exports” directory on the user’s hard drive.

3.	 Note the File Save Prefix and change if desired. The prefix will become the first part of the file name. By default, 
this prefix identifies the file by Scanner model and download type.

4.	 Click OK to export.

5.	 Wait momentarily while Scanner Data Manager opens an email window on your computer, attaches the export 
file(s), and embeds a brief description of the file(s) in the body of the email (Figure 3.7, page 37).

Note 	 Check the size of the export file. It may be necessary to compress (.zip) large files before emailing them.
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Figure 3.6—Email Files dialog

Figure 3.7—Automated email for multiple files
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Emailing Data Converted to Flow-Cal or PGAS Formats
To email the contents of the archive file in a third-party Flow-Cal (.cfx) or PGAS (.ana/.evt/.vol) format

1.	 See Section 5—Converting Data, page 63, for information on changing conversion settings. This may be espe-
cially useful if gaps in the data are expected. 

2.	 Click on the Email Data button in the left column of the screen and click the appropriate Email All as... selection 
from the dropdown menu (Figure 3.3, page 34). 

3.	 Note the “File Save Directory” location and change if desired. By default, files are saved to the “C:\Cameron Data\
SDM\Exports” directory on the user’s hard drive.

4.	 Note the File Save Prefix and change if desired. The prefix will become the first part of the file name. By default, 
this prefix identifies the file by Scanner model and download type.

5.	 Click Save to export.

6.	 Wait momentarily while Scanner Data Manager opens an email window on your computer, attaches the conversion 
file(s), and embeds a brief description of the file(s) in the body of the email (Figure 3.8).

Figure 3.8—Automated email generated for converted files

Emailing an Archive (SDF or SCM) File
To email an archive file (SDF/SCM) to a technician or another Scanner Data Manager user, click the Email Archive File 
button on the left side of the main screen (Figure 3.9, page 39). 

Scanner Data Manager will automatically open an email window on the user’s computer, attach the archive file, and em-
bed a brief description of the file in the body of the email (Figure 3.10, page 39).

Note	 The SDF/SCM file formats are proprietary and can be viewed only with Cameron software products designed for 
this purpose. To share the contents of the archive file in a common format that can be opened outside of Scanner 
Data Manager, see Exporting Tabular Data, page 31, Emailing Tabular Data, page 35, and Exporting Trend 
Data, page 40.
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Figure 3.9—Location of Email Archive File button

Note 	 Check the size of the export file. It may be necessary to compress (.zip) large files before emailing them.

Figure 3.10—Automated email generated for archive file
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Exporting Trend Data
Trend data may be viewed by record or by date/time, and exported to PDF, RTF, BMP, JPG, and GIF image formats. See 
Customizing the Trend Graph View, page 17 and Viewing Trends by Date/Time, page 22 for details about viewing 
options.

To export trend data, follow the procedure below:

1.	 Click the tab for the log type desired and apply any filters or sort order selections desired. 

2.	 Select the desired viewing option (by record or by date/time), and click the View Trends button on the left side of 
the main screen.

3.	 Configure the trend view that you want to export using the zoom and parameter display tools on the View Log 
Trends screen. 

4.	 When the trend image is exactly as you want the export file to appear, click on the Export button at the top left of 
the View Log Trends dialog (Figure 3.11).

5.	 Select the export file type from the dropdown list.

Note	 Exported files will appear exactly as they do on screen with the following exceptions. Trend View PDF files will 
have a white background when viewed electronically or printed. All exported trend files will contain a header, 
footer, and a legend detailing the trend lines.

6.	 Change the filepath if desired. By default, export files are saved in the “C:\Cameron Data\SDM\Exports” directory 
on the user’s hard drive.

Record Index

Figure 3.11—Log Trend view showing Export button and dropdown menu
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7.	 Change the filename if desired. By default, the filename includes the flow computer model, the type of download, 
the flowrun number, and a log type indicator (for example, S3100_Local_1_TH.xlsx).

8.	 Click Save to export the trend image.

9.	 Repeat Steps 3 through 8, as desired, to capture more sections of the trend log.

10.	 Click the Done button in the upper right corner of the View Log Trends dialog to exit the trend view. 
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Section 4—Generating Reports
Flow data, device configuration and calibration data, events, and alarms can be captured in a report that can be printed 
as a hard copy or exported to PDF format for distributing electronically. Scanner Data Manager supports two types of 
reports: 

•• A standard report with a pre-defined layout that matches the main screen layout (see Standard Reports, page 44 
and Figure 4.1)

•• A custom report that allows the user to specify content and personalize the presentation with a company name, logo, 
and contact information (see Custom Reports, page 49 and Figure 4.1).

Production ReportSuccess Valley, USA 12345
Suite A
1234 Excellence Circle

Device/Meter Name:
Company Name
Site/Well Name:
Field/Lease Name
Location Name:

S3100
Company
Site
Field
Location

Downloaded on:
SDM:
Device Type:
Firmware:
Board ID:
Device SN:

2014-11-06 10:56:44
1.0.0

S3100-G1
1.026

0
6291470LegalLegal Description November 03, 2014

Contract Hour
Pipe Size

8:00 AM
50.800 mm

Plate Size 40.640 mm Atm. Press.
Base Press.

101.3250 kPa
0.0000 kPa

Date/Time Volume
m³

Mass
kg

Energy
MJ

Diff. Pres.
kPa

Stat. Pres.
kPa(g)

Temp.
°F

Flow
Time

s

2014-11-03 17:21:29 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 17:26:04 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 18:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 19:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 20:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 21:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 22:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-03 23:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 00:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 01:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 02:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 03:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 04:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 05:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 06:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 07:00:00 0.000 0.000 0.000 0.000 0.000 INF   0
2014-11-04 08:00:00 0.000 0.000 0.000 0.000 0.000 INF   0

0.000 0.000 INF
0.000 0.000 0.000   0

Average
Minimum
Maximum
Total

1 of 2 Created On: 2014-11-10 19:24Scanner Data Manager - Daily Report

CUSTOM

Figure 4.1—Comparison of standard report vs. custom report
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Standard Reports
A standard Scanner Data Manager report can be generated for any data type. Data types vary depending on the Scanner 
device used to generate the data. Table 4.1 provides a brief overview of typical report types and their contents. 

Table 4.1—Standard Reports
Report Description

Interval/Hourly History Displays data generated for pre-defined intervals and parameters, including Flow 
Run Volume, Flow Run Mass, Flow Run Energy, Differential Pressure, etc. Each 
record includes the Record Number and Timestamp.

Daily History Displays data generated for a 24-hour period, including Flow Run Volume, Flow Run 
Mass, Flow Run Energy, Differential Pressure, etc. Each record includes the Record 
Number and Timestamp.

Configuration (System and 
Flow Run)

Displays the system and flowrun configuration settings in one or two tabs, depending 
on the Scanner device in use. Scanner 3100 slave data are stored in separate tabs.

Snapshot Displays live and calculated parameters for a user-specified point in time.
Alarms Displays alarm activity for the Scanner. An alarm log is generated each time a 

selected parameter deviates from its user-selected set point(s). Alarms are logged 
by date and time. Each record includes the Modbus register name, status or type of 
alarm activated, and the associated value and unit, where applicable.

Events Displays user changes, such as K-Factor, orifice meter factor, cone meter factor, 
plate and cone size, gas composition, input settings and resets. Events are logged 
by date and time. Each record includes the Modbus register name, as well as the old 
and new values of the parameter. For the Scanner 2x00 series, the events and user 
changes reports are one report, whereas the Scanner 11xx and Scanner 3100 have 
separate reports for events and user changes.

User Changes Displays user changes, such as K-Factor, orifice meter factor, cone meter factor, 
plate and cone size, gas composition, input settings and resets. Events are logged 
by date and time. Each record includes the Modbus register name, as well as the old 
and new values of the parameter. This report appears as a separate report for the 
Scanner 11xx Series and the Scanner 3100.

Calibrations† Displays the instrument’s input calibration settings for quick reference. 
†Calibrations and user-initiated changes for Scanner 11xx devices are stored under a User Changes tab. To generate a Scanner 11xx 
Calibrations report, the user must connect to the Scanner 11xx device through ScanWin, the proprietary software interface for Scanner 
11xx devices.

For some log types and reports, archive data is divided into multiple tabs at the bottom of the screen (Figure 4.2, page 
45). For example, interval and daily history data are divided by flowruns. Similar divisions exist for alarms, events, 
and slave device configuration data.

Where a log type or report includes multiple tabs, the user has the option of creating a report for a single “current” tab 
or for “all” tabs. Log types and report types containing these options are identified by the dropdown arrow on the Print 
[Data Type] button at the left of the screen (Figure 4.2, page 45). 

Creating a Standard Report for “Current” Tab
To create a standard report for the “current” selected tab (for example, Flow Run 1 of a multi-flowrun log)

1.	 On the main screen, click on the data type (tab) for which you want to create a report (Interval History, Daily Histo-
ry, Configuration, etc.). Note that the Print button under the “Reports” section on the left side of the screen changes 
to reflect the data type (tab) selected.

2.	 If the archive file contains multiple flowruns or otherwise divides log data between multiple tabs, click the desired 
tab at the bottom of the screen. 

Note	 For information on creating a standard report for data collected from multiple flowruns, see Creating a Standard 
Report for “All” Tabs, page 48.
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3.	 Click the Print [Data Type] button and select “Current [Data Type]” from the dropdown menu (Figure 4.2, page 
45). A preview of the report will appear (see Figure 4.3, page 46).

4.	 Check the formatting of the preview. If desired, change the page format settings using the Page Setup dialog (Figure 
4.4, page 46) on the Preview screen. From this dialog, changes can be made to page orientation, margin size, 
header and footer size and content, and scaling of the data grid.

Note	 Changes made to the Page Setup dialog apply only to the current report(s) being created and are not saved 
when closing Scanner Data Manager.

Figure 4.2—Daily History and Alarm tabs showing data divided into multiple tabs
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Figure 4.3—Print preview screen in landscape orientation (default)

  
Figure 4.4—Page Setup window, orientation setting 

Printing a Standard Report
To print a standard report

1.	 Click the Print Dialog button in the top left corner of the Print Preview screen (Figure 4.5).

2.	 Verify that the printer selected is appropriate for your computer. Change the printer selection if desired.

3.	 Note the page range listed in the lower left corner of the Print dialog. Change the range if desired.

4.	 Click Print.

CAUTION	 	 Large files can result in reports that are several hundred pages in length. Note the page count in 
the footer of the Print Preview screen before printing and adjust the page range if desired.
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Figure 4.5—Print Dialog window

Note	 If multiple reports are to be printed and the same settings will be used for all, you can bypass Step 1 above after 
you verify the settings for the first printing, and click the Print icon at the top of the Print Preview screen to print 
subsequent reports without a preview.

Exporting a Standard Report to PDF
The following procedure is recommended for generating a PDF when changes to the presentation (such as page size, 
margins, orientation, etc.) are desired. If no formatting changes are desired, the export features described in Exporting 
Tabular Data, page 31 and Exporting Trend Data, page 40 can be used to generate a PDF report. 

1.	 Click the Export to PDF button in the top left corner of the Print Preview screen. A PDF Export Options dialog 
will appear, as shown in Figure 4.6.

2.	 Adjust the pages to be exported if desired on the Pages tab.

3.	 Click OK to exit the PDF Export Options dialog. A Save As dialog will open.

4.	 In the Save As dialog, verify or change the filepath and enter a unique filename for the PDF. The default filepath is 
“C:\Cameron Data\SDM\Exports”.

5.	 Click Save to create the PDF.
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Figure 4.6—Export to PDF menu

Creating a Standard Report for “All” Tabs
If a download file includes more than one flowrun and all flowrun data for a selected log type or report are to be included 
in a report, use the following procedure to create the report.

To create a standard report for all tabs (for example, Flow Runs 1 and 2 of a two-flowrun log)

1.	 On the main screen, click on the data type (tab) for which you want to print a report (Interval History or Daily His-
tory). Note that the Print button under the “Reports” section on the left side of the screen changes to reflect the data 
type (tab) selected.

2.	 Click the Print [Data Type] button and select “All [Data Type]” from the dropdown menu (Figure 4.7, page 48). 
The Print dialog will appear (Figure 4.8, page 49).

Figure 4.7—Reports>Print dropdown menu with “All [Data Type] History” selected

3.	 Select Preview in the bottom left corner of the Print dialog.

Note	 If multiple flowruns are included in the report, preview screens will display flowruns one at a time. For example, if 
a report contains Flow Run 1 and Flow Run 2, Flow Run 1 will be displayed in the first preview dialog. The user 
must close the preview screen for Flow Run 1 before the preview for Flow Run 2 will appear.

48

Section 4	 Scanner Data Manager



Figure 4.8—Print dialog showing Preview button

4.	 Follow the instructions for Printing a Standard Report, page 46 and Exporting a Standard Report to PDF, page 
47.

5.	 If a report for another data type is desired, click the tab for that data type and repeat the steps above. 

CAUTION	 	 Large files can result in reports that are several hundred pages in length. Note the page count in 
the footer of the Print Preview screen before printing and adjust if required.

Custom Reports
Scanner Data Manager provides some simple tools for creating custom, personalized reports on demand, complete with a 
company name, logo, and contact information. See Figure 4.9 for a sample custom report.

Two template types are included in the program:

•• Generic Template—includes parameters that are common to all Scanner devices (recommended for users who want 
to create a series of reports that contain the same information in the same order)

•• Production Report Template (Scanner-specific)—reflects the available inputs and outputs of the device in addition to 
the basic parameters in the generic template 

The template files are easily modified to meet a user’s needs. A user can add or delete parameters (columns), rename pa-
rameters, change the order in which parameters appear, and save changes as a new template for future use. It is recom-
mended that users follow three simple steps to create a custom report:

1.	 Define common default settings, which will be available for use in all report templates. See Setting Common De-
faults, page 50 for more details.

2.	 Modify a model-specific Production Report template and save as a new template. See Configuring Columns, page 
53 and Changing Extra Headers and Summary Items, page 55 for more details.

CAUTION	 	 Modifying a Scanner-specific Production Report will overwrite the existing template. See Adding 
and Deleting Templates, page 52 to learn how to create a new template without overwriting the 
existing template.

49

Scanner Data Manager	  Section 4



3.	 Generate a custom report using the Custom Report Options dropdown menu accessed from the main screen. See 
Figure 4.10, page 50 and Viewing and Printing a Custom Report, page 57.

Logo

Summary
Items

Text Block

Extra 
Header 

Items

Figure 4.9—Sample custom report showing customizable elements

Setting Common Defaults
Common defaults are options that apply to every report template regardless of the data source or Scanner device.

To establish these defaults, choose Options>Custom Report Options (Figure 4.10). The dialog will automatically open 
to the Common Defaults screen (Figure 4.11).

Figure 4.10—Options>Custom Report Options
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Figure 4.11—Custom Report Options screen showing Common Defaults dialog 

From this dialog, the user can change the following settings to meet specific needs:

Note	 Changes made to the Common Defaults report will apply to all templates unless changed.  

Page Size
By default, reports are configured to be letter size. Use this option to change the page size.

Orientation
Users can print or export reports in Landscape (wide) or Portrait (long) orientation. Landscape orientation is recom-
mended for reports containing a large number of columns or extra headers because it allows more columns to appear on a 
single page.

Logo
This option allows the user to include a company logo within the header. The logo will appear in the upper right corner 
of the report. File formats BMP, JPG, JPG, PNG, EFM, and WMF are supported. 

Address/User-Specified Text
Three lines of user-specified text can be used for a company/customer address or other text the user may wish to add to 
the report header. Text will appear in the order it is entered by the user and will be displayed in the upper left corner of 
the page. 

Extra Header Items
A basic set of parameters, such as device/meter name, company name, site/well name, firmware version, and device seri-
al number, is included in the standard header of all reports. However, custom reports allow the user to include other con-
figuration items in a second header (Figure 4.11, page 51). The user can select which parameters to include and change 
the text description used to identify a parameter by entering text in the “User Text” field. Extra header selections avail-
able will vary, depending on the device used to generate the archive file.

Note	  The “User Text” field will accept up to 15 characters.
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Summary Rows
Summary rows enable the user to include in the report a value such as a total or average that is calculated over a logging 
period. The logging period could be a month for daily logs or a day for interval logs. These rows are presented in the or-
der shown on the screen. Up to five summary rows are supported: Average, Flow Time Weighted Average (the average of 
values accumulated when measurable flow exists), Minimum Value, Maximum Value, and Total. As a default, the select-
ed Type name will be used to define summary items in the report, but the user can override this text by editing the text in 
the “User Text” field. Each type can be used; however, types cannot be repeated within a report.

Production Report Templates
Report templates are individual templates from which a user can create custom report templates. By default, there are 
standard production report templates for each Scanner device, as well as a Generic template that contains parameters 
common to all Scanner devices (Figure 4.12).

 

Common Defaults, 
Generic Production 

Report and 
Scanner-specific  

Production Report 
templates

Figure 4.12—Production Report template customization options

Adding and Deleting Templates
To add a template, select the device category (Generic, Scanner 11xx Series, Scanner 2x00 Series, or Scanner 3x00) and 
click the Add button on the bottom left of the Custom Report Options dialog (Figure 4.12, page 52). A blank template 
based on the device category selected will appear. The user can customize the template, rename it, and save it as a new 
template by clicking the Save Template button on the bottom right of the screen.

To delete a user-created template, select the template and click the Delete button on the bottom left of the screen (Figure 
4.12, page 52). Default templates for each device type can be modified. However, users should proceed with caution. 
Changes to default templates are permanent and the original templates can only be restored by reinstalling the Scanner 
Data Manager software.

Note	 Modifying a model-specific Production Report template without adding a new template will overwrite the default 
Production Report template.

Creating a New Report Template
Each Production Report template contains three views (Columns, Common Overrides, and Page Overrides) accessed by 
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three tabs at the bottom of the screen (Figure 4.12, page 52). 

•• The Columns tab allows the user to select the parameters (columns) to include in the report and to change the order 
in which the data appears. 

•• The Common Overrides tab allows the user to add extra header and/or summary items.

•• The Page Overrides tab allows the user to change the page layout, logo, and address. From the Columns tab, the user 
can name a report template, select the parameters (columns) that will appear within the report, and change the order 
in which they appear.

CAUTION		  If you do not save the template before exiting or before switching to another template, all 
changes will be lost. It is recommended that the customized template be given a unique name, 	
rather than overwriting the standard template. If the default Production Report template is  
overwritten, the user must unzip the backup files to restore the templates.

Configuring Columns
To establish the Columns tab settings for a new template

1.	 Click on the device type for which you want to create a new template, then click the Add button that appears on the 
bottom left of the Custom Report Options dialog to create a blank template. By default, it will appear on the Custom 
Report Options dialog as “Report.”

2.	 Replace the text in the “Report Name” field at the top of the screen to assign a name that uniquely identifies it.

Note 	 The “Device Type” field is read-only and is self-populated to reflect the template selected. This field is informa-
tional only. 

3.	 Verify that the Columns tab at the bottom of the screen is selected.

By default, the first column is Date/Time (same as shown in the log grids), and represents the end of the interval/day. 
If the History timestamp is changed to mark the beginning of the record, the Date/Time entries will represent the be-
ginning of the interval/day.

Note	 If a beginning date and time is desired as well as an end date and time, add a new column for Date/Time as 
described below and move it to the Column 2 position in the grid. Column 1 will display the “from” date and time, 
and Column 2 will display the “to” date and time for the range. To move a column to a new position, see Chang-
ing Parameters (Columns), page 54.

4.	 Add parameters to the data grid in the center of the screen as follows.
a.	 Click the Add Column button at the right of the data grid. The Add Column dialog (Figure 4.13, page 54) 

will appear.

b.	 Select the parameter desired.

c.	 If the parameter being added is associated with a flowrun or gas stream, the Add Column dialog will include 
a user entry field for “FR or GS Index.” In typical use cases, where archive 1 is configured with flowrun 1 pa-
rameters and archive 2 is configured with flowrun 2 parameters, use the default value of 0. In the event flowrun 
1 and flowrun 2 parameters are combined in a single archive, the index value allows the user to specify which 
flowrun value is to be included in the report. For example, to add a column for Flow Run 1 Volume, select 
Flow Run Volume as the data type and enter an index value of 1. 
 
In the case of gas streams, the user identifies the type of gas in the data type field, and enters an index value to 
designate the flow stream desired. For example, to include data from Gas Stream 5, enter an index value of 5.

Note	 The “FR or GS Index” field will only appear for Scanner 3x00 parameters that are related to a flowrun or gas 
stream.
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d.	 Enter a new parameter text description in the “User Text” field if desired. 

e.	 Change the decimal places, if applicable. Up to seven decimals can be configured.

f.	 Change the column width, if desired. If you select a width that is too small, the data in the column may overlap 
the previous column. Column width may be selected in unitless increments of five. Typically, column width is 
changed only after all parameters are entered and the user can determine if width adjustments are required to 
present the data properly.

g.	 To add the parameter to the bottom of the report in a summary row, select the checkbox(es) under “Include in 
Summaries” to indicate the type of summary calculation required (average, weighted average, minimum value, 
maximum value, or total). The selections available depend on the data type and whether summary calculations 
are supported by the Scanner device used to generate the data.

By default, the summary rows enabled as Common Defaults will automatically apply to all existing templates 
unless they are overridden from the Common Overrides screen. See Summary Rows, page 52 and Changing 
Extra Headers and Summary Items, page 55 for details.

Figure 4.13—Add Column dialog

h.	 Click OK to save changes, close the Add Column dialog, and add the column to the report.

5.	 Click Save Template in the bottom right corner of the Custom Report Options dialog above “OK” and “Cancel” to 
save your progress.

All new columns will be added to the bottom of the grid on the Custom Report Options dialog, and to the far right of the 
Column Preview bar. To move a column to a new position, see Changing Parameters (Columns), page 54.

The number of columns included in a generated report will vary depending upon page orientation and total column 
width. The “Columns in Report” section of the Custom Report Options screen (Figure 4.12, page 52) indicates the to-
tal estimated number of columns to be included. If additional parameters are required, simply create another customized 
report. If a parameter is not available within an archive file, it will be skipped and the next available parameter for which 
data exists will be listed. 

Changing Parameters (Columns)
Parameters (columns) can be added or deleted, and moved left or right on the report (up or down on the grid) using the 
appropriate buttons. 

Note 	 To move a parameter (column) left or right, click a parameter to highlight it in the grid, and click the Move Left 
or Move Right button. The selected data row will move up or down within the grid, but in effect, the column con-
taining the grid data is moving to the left or right, as shown in the “Column Preview” grid near the bottom of the 
screen.

To make changes to an existing column (to include data type, data type description, decimal format, column width, or 
summary item selections)
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1.	 Click the Change Column button on the Custom Report Options screen.

2.	 Make desired changes on the Change Column dialog (Figure 4.14).

3.	 Click OK.

Figure 4.14—Change Column dialog

Changing Extra Headers and Summary Items
From the Common Overrides tab (Figure 4.15, page 56), the user can override extra header items and/or summary 
items. Overriding these settings may affect how the columns appear and which summary items appear on the generated 
report.

To establish the Common Overrides tab settings for a new report

1.	 From the Custom Report Options dialog, select the template being created.

2.	 Click on the Common Overrides tab at the bottom left of the screen.

3.	 To change or add extra header items, click the Override Extra Header Items checkbox. 

4.	 Select the data type from the dropdown menu to add it to the header. The data types in the dropdown menu vary 
depending on the type of data obtained from the Scanner device. To change the display text, enter the desired name 
for the type in the “User Text” field. 

Note 	 By default, extra headers that are enabled as Common Defaults will automatically apply to all existing templates 
unless they are overridden on the Common Overrides screen. To disable these items from a Scanner-specific 
template, navigate to the Common Overrides tab and check the Override Extra Header Items checkbox, leav-
ing all the header items labeled “unused.”

5.	 To add or change the summary items for a selected data type, click the Override Summary Items checkbox.

6.	 Select the desired summary type from the dropdown menu. The summary types available will depend on the data 
type selected. By default, the summary type description will be displayed in the report. To change the display text, 
enter the desired name for the summary item in the “User Text” field.
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Figure 4.15—Common Overrides tab

7.	 Click Save Template to save your changes. 

Customizing the Page Layout
From the Page Overrides tab (Figure 4.16, page 57), the user can change the pages size and/or orientation, add or 
change a logo, and add or change an address or text block to the report template.

This feature is especially helpful for users who want to generate a custom report with customer-specific information and 
graphics for each of their customers.

To establish the Page Overrides settings for a new report
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1.	 From the Custom Report Options dialog, click on the Page Overrides tab. 
 

	

Figure 4.16—Page Overrides tab

2.	 To change the page size and orientation, check the Override Page Layout box.

3.	 To add or change a logo, click the Override Logo box, then click Load Image, browse to the logo’s location, and 
click on the file.

4.	 To add or change an address, click the Override Address box and enter text in the three fields below. The informa-
tion will appear on the report in the order in which it is entered. 

Note	 It is not necessary to enter information in every field; however, if more than one field is used, enter the informa-
tion from the top down and do not leave the first row blank.

5.	 Click OK to save changes and return to the Tabular View dialog.

6.	 Click Save Template to save the new template.

Viewing and Printing a Custom Report
To view and print a customized report, 

1.	 Click on the Custom Reports button on the left side of the main screen (Figure 4.17, page 58). The Custom Re-
ports dialog (Figure 4.18, page 58) will appear, from which the final look of the report can be defined. 

Note	 The Custom Reports button is only enabled for the Interval and Daily Log tabs. Other tabs do not support this 
feature.
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Figure 4.17—Custom Reports button on main screen

Figure 4.18—Custom Reports dialog 

2.	 From the Select Template dropdown menu, select the desired template for use in generating the report. At a minimum, 
available templates will include a generic template and a Scanner-specific template. To add custom templates to this 
list, see Creating a New Report Template, page 52.

3.	 Select from the available report types:

•• Monthly Report containing data from Daily Logs

•• Daily Report containing data from Interval Logs

If a log type (daily or interval) is not available in the archive file, the option for that report type will be unavailable 
and the selection will default to the available option.

4.	 In the “Select Flow Runs” field, select the flowruns/archives for which reports are generated. Available selections 
vary depending on the device type used to produce the archive file.

5.	 Specify the dates and times to be included in the report from the “Select Date Range” field:

•• All Dates/Times containing all date and time ranges within the archive file

•• Selected Dates/Times containing

–– A range by month and day

–– A user-defined range, including start date and end date
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Note	 The ranges available are limited to the dates and times included in the available data. 

Note	 If the logs contain data of differing ranges, some reports may not include all the data or may fail to generate. For 
example, if you choose to print all flowrun/slave device reports for February and Slave Device 6 was not added 
until March, there will be no data for Slave Device 6 and no report will be generated for that device. 

6.	 From the “Select Output” field, choose one of the following output options:

•• Print Preview—Displays a preview of each flowrun report before printing

•• Output to Printer—Sends the report file directly to the default printer

•• Output to File—Saves the report file in the user-specified format to the user-specified directory 

When “Output to File” is selected, the user can define the output with several additional optional settings:

•• Check Email File(s) if the output file to automatically attach the output file to an email window.

•• Check Open After Export to automatically open the report on the computer screen.

•• Click the File Format dropdown menu and select the file type. Options are PDF, RTF, .html, .xls, or .txt format.

•• Enter a file prefix, if desired, for ease in categorizing reports for quick identification.

•• Modify the “Output Directory” filepath, if desired. The default directory is “C:\Cameron Data\SDM\Reports”.

•• Check Output Files to Field Name and Site Name Subdirectories to create Field Name and Site Name sub-
folders on your hard drive for storing the reports (“C:\Cameron Data\SDM\Reports\<Field_Name>\ 
<Site_Name>”).

7.	 Click the Create button to generate a report template. The settings used to generate the report will be saved as a 
starting point for creating additional reports.

8.	 Click the Close button to exit the Custom Reports dialog.

Important		  If you click the Close button and close the Custom Reports dialog without clicking the Create button 
and generating a report, the selected settings will not be saved for future use.

Printing a Legally-Relevant Log
To meet Measurement Canada  requirements, Scanner Data Manager enables you to print a log of legally-relevant user 
changes. Depending on user activity, the log may contain configuration and/or calibration data.

Important	 	 To use this function, Configuration Lock mode must be enabled in the Scanner 3100 web interface. 
See the Scanner 3100 Web Interface manual for further information about enabling Configuration 
Lock mode.

Legally-relevant user changes are configured in the web interface. For more information, refer to the Scanner 3100 Web 
Interface User Manual.

To print a legally-relevant log,

1.	 Open the desired SDF file by browsing to the file and double-clicking or by opening Scanner Data Manager and 
choosing File>Open.

2.	 Once the file is loaded, click on the User Changes tab. To view the legally-relevant items, scroll to the last column 
on the right. All items with checkmarks will appear in the legally-relevant log report.
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Important		  The User Changes report shows both legally-relevant and non-legally relevant user changes. You 
must select the legally-relevant items to isolate them in the report. See step 3 below for more infor-
mation.

 Note	 Items marked as legally-relevant are read-only and cannot be deselected by unchecking the box.

3.	 To sort the legally-relevant information, click the dropdown arrow in the Legally-Relevant column and select True. 
This will isolate the legally-relevant changes and allow you to print a report showing only those changes.

4.	 To print the current log, click Print User Changes>Current User Changes tab (Figure 4.19 1, page 60). A print 
preview will appear (Figure 4.20 1, page 61). 

Note	 To fit all columns to the page, click Close Print Preview to return to the log, and then click and drag the vertical 
column bar to resize them.

Figure 4.19—User Changes tab
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Figure 4.20—Print preview of a Legally-relevant User Change log

5.	 From the Print Preview screen, click the Print button to print the report (Figure 4.21 1, page 62).
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Figure 4.21—Print button location
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Section 5—Converting Data
Scanner Data Manager offers both individual file conversion and batch conversion. Data can be converted and saved in 
third-party Flow-Cal and PGAS formats, as well as in formats that are specific to Scanner 11xx devices.

Batch Conversion
Batch Conversion allows the user to convert multiple files to a different file format at the same time. Archive data can be 
batch converted to FlowCal, PGAS, BDMS Generic (11xx only), and GDS (11xx only) formats. 

Note 	 For a complete understanding of filepath locations, default settings, and file naming options, review the Conver-
sion Options dialog described below before attempting a batch conversion.

Conversion Options
Archive data (SDF/SCM) files are automatically archived upon conversion, ensuring a complete measurement audit trail. 

File Locations
Figure 5.1 shows the default filepaths provided for storing input data files and converted files. To assist with trouble-
shooting, input data files for successful conversions are stored separately from input data files for failed conversions. 
Likewise, output files for successful conversions are stored separately from output files for failed conversions.

By default, 

•• Archive files that are successfully converted are stored in “C:\Cameron Data\SDM\Convert\Archived.”

•• Archive files associated with failed conversions are stored in “C:\Cameron Data\SDM\Convert\Failed.”

•• Output files that are successfully converted are stored in the user-defined directory that is entered on the Batch Con-
version screen (see Figure 5.8, page 67).

•• Output files associated with failed conversions are stored in “C:\Cameron Data\SDM\Convert\Output.”

Users may edit these filepaths if desired.

Figure 5.1—Conversion Options dialog
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Status Log
Following conversion, a status log providing conversion details is automatically displayed on screen and stored in the log 
directory specified in the “General Logging Settings” section of the Conversion Options screen (Figure 5.1, page 63). 

The level of detail is determined by the logging level selected from Options>Logging Level. If a detailed status log is 
desired, check the Use Advanced Logging checkbox, and note the filepath for this log. If errors occur, the log can help 
indicate the source of the problem.

If the user chooses a conversion type that is not supported by the archive file, the file will not be converted and it will be 
moved to the “Failed” directory as defined on the Conversion Options>File Locations screen.

Flow-Cal Conversion Options
To access conversion options for Flow-Cal, select Options>Conversion Options from the main screen (Figure 5.1, 
page 63).

When the Conversion Options dialog appears, choose FlowCal Defaults and specify the following options:

•• File Format [Scanner 2x00/3x00 only] (Figure 5.2)—Select Flow-Cal Version appropriate for the flowrun. If the 
flowrun is a liquid run, enter the Flow-Cal product code in the “Liquid Product Code” field. If no product code is 
entered, the code will default to “MYGRADE.”

Note:	 Flow-Cal Version 8.x supports the following calculation methods: AGA-3 (2013), AGA-3 (1992), AGA-7, ISO 
5167, API 14.3.3 (Inferred Volume), and API 12.2 (Liqud Volumetric). In addition, Version 8.x supports cone, 
turbine, and other meters; Monel, Monel 400, 304 Stainless Steel, and 316 Stainless Steel pipe and plate materi-
als (plus those covered by all previous versions); and gas composition reporting (history archive) [Scanner 3x00 
only].

•• File Naming [Scanner 11xx only] (Figure 5.2)—Select Node Name + Flowrun Number or Flowrun Name in the 
“File Name” field and/or the “Station Number” field

•• Common Defaults (Figure 5.3, page 65)

•• Orifice Defaults (Figure 5.4, page 65)

•• Pulse Defaults (Figure 5.5, page 65)

Note	 Common defaults, orifice defaults and pulse defaults are defined by Flow-Cal. Refer to the Flow-Cal documenta-
tion for information about what values should be entered.

To specify these options, click on the option to be changed and enter the parameter(s).

Figure 5.2—Flow-Cal General Options dialog
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Figure 5.3—Flow-Cal Common Defaults dialog

Figure 5.4—Flow-Cal Orifice Defaults dialog

Figure 5.5—Flow-Cal Pulse Defaults dialog
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PGAS Conversion Options
To access conversion options for PGAS, select Options>Conversion Options from the main screen.

When the Conversion Options dialog appears, choose PGAS Defaults. Conversion to PGAS format allows the user to 
specify Meter_ID Settings, Flowrun Support, Missing First Record Data/Time Settings, and Default Logging Interval by 
selecting the desired option(s) from the dialog (Figure 5.6).

Figure 5.6—PGAS Defaults dialog

Cameron archives only provide an ending timestamp and PGAS requires a starting time for the first record and an end-
ing timestamp. To establish a starting time for the first record, select Blank Values, which leaves the timestamp blank, 
or Use Default Logging Intervals to Compute, which calculates a starting timestamp based on the default logging 
interval. 

Performing a Batch Conversion
To perform a batch conversion of files to a third-party software format, 

1.	 Place the files to be converted in a dedicated directory. 

2.	 Choose File>Batch Conversion from the main screen (Figure 5.7). The Batch Conversion dialog will appear (Fig-
ure 5.8, page 67).

Figure 5.7—File>Batch Conversion

3.	 From the Batch Conversion dialog
a.	 Select the “Input” directory (the dedicated directory established in Step 1)
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b.	 Select the files to be converted (the default setting is “All Files”). If selecting individual files for conversion, 
choose Selected Files, press and hold the <Ctrl> key and select each desired file from the list displayed.

c.	 Select the type of conversion desired. If the conversion format selected is not supported by the file data, the file 
will not be converted and it will be moved into the “C:\Cameron Data\SDM\CONVERT\FAILED” directory.

d.	 Select the output directory where converted files will be stored.

Figure 5.8—Batch Conversion dialog

4.	 Click the Convert button to begin the conversion. 

5.	 When the conversion is complete, the View Logs screen will automatically open to provide status information. If the 
Use Advanced Logging option on the Conversion Options dialog is enabled, advanced logs tab shows additional 
details about the conversion.

6.	 To exit the Batch Conversion mode, click Done.

Converting a Single File to Flow-Cal or PGAS Format
To export the contents of an archive file to Flow-Cal (.cfx) or PGAS (.ana/.evt/.vol) format

1.	 See Conversion Options, page 63 for information on changing conversion settings. This may be especially useful 
if gaps in the data are expected. 

2.	 Click on the Export Data button in the left column of the main screen and choose the desired Export All to... selec-
tion from the dropdown menu (Figure 5.9, page 68). 

3.	 Click Save to export the data.

Emailing Converted Flow-Cal or PGAS Files
To convert and email the contents of an archive file in Flow-Cal (.cfx) or PGAS (.ana./.evt/.vol) format

1.	 See Conversion Options, page 63 for information on changing conversion settings. This may be especially useful 
if gaps in the data are expected. 

2.	 Click on the Email Data button in the left column of the screen and choose the appropriate “Email All as...” selec-
tion from the dropdown menu (Figure 5.10, page 68). 

3.	 Click Save to save the file.

4.	 Wait momentarily while Scanner Data Manager opens an email window on your computer, attaches the conversion 
file(s), and embeds a brief description of the file(s) in the body of the email (Figure 5.11, page 69).
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Figure 5.9—Export Data button and dropdown menu

Figure 5.10—Email Data button and dropdown menu
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Figure 5.11—Automated email generated for converted files

69

Scanner Data Manager	  Section 5



This page is left blank intentionally.

70

Section 5	 Scanner Data Manager



Appendix A—Changing Measurement Units 
The data format and units of measurement displayed when a download file is opened in Scanner Data Manager are based 
on the configuration of the Scanner flow computer that generated the download file. This appendix describes how to 
override the default settings in the download file. To change unit settings or decimal values, click Options>Viewing Op-
tions and click the Scanner device in use in the menu at the left side of the dialog. Settings vary with Scanner models. 
Examples of each set of device settings are provided below.

Scanner 3100 Units
From the Scanner 3x00 Viewing Options dialog (Figure A.1), the user can change the unit, rate, decimal position, or for-
mat of a parameter and override the unit in the SDF file. If a Scanner 3100 archive file contains slave device data, over-
ride selections will apply to the slave device data too.

To change the way a parameter is displayed,

1.	 Check the Override Units checkbox near the top of the screen to make the unit selections editable.

2.	 Both US Customary and SI units are provided in the dropdown menu for parameters. However, for added conve-
nience, a user can change the default units, rates, decimals and formats for all parameters to SI or US Customary by 
clicking the SI Units or US Customary button near the top of the screen.

3.	 Click the cell containing the selection to be changed to open a dropdown menu and make the desired selection.

•• Rate selections include per second, per minute, per hour, and per day.

•• Up to seven decimal places are available for any unit.

•• Parameters can be displayed in fixed point or scientific notation.

4.	 Click OK. All changes to units will be saved, even if the Override Units checkbox is left unchecked. This allows the 
user to switch between units defined in the archive file and the units specified in Scanner Data Manager.

Figure A.1—Scanner 3x00 unit override screen
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Scanner 2x00 Units
Note	 This dialog pertains to SDF files downloaded using ModWorX Pro software and to Scanner 2x00 devices in-

stalled as Scanner 3100 slave devices.

From the Scanner 2x00 Viewing Options dialog (Figure A.2), the user can change the unit, rate, decimal position, or cat-
egory of a parameter and override the unit in the SDF file. 

Changing Parameter Displays
To change the way a parameter is displayed,

1.	 Check the Override Units checkbox near the top of the screen to make the unit selections editable (Figure A.2).

2.	 To change the category for Analog Input 1 or Analog Input 2, click in the “Category” field and selecting the desired 
category (Differential Pressure, Static Pressure, Temperature, etc.) from the dropdown list.

3.	 To change individual units, click the cell containing the selection to be changed to open a dropdown menu and make 
the desired selection.

•• Units of measure include SI and US Customary selections.

•• For the Scanner 2x00, units default to US Customary units.

•• Rate selections include per second, per minute, per hour, per day, per week, per month, and per year.

To revert back to the factory default units after entering one or more unit changes, the user can restore the default 
units for all parameters without leaving the screen. Simply click the Defaults button near the top of the screen to re-
store factory default units.

Figure A.2—Scanner 2x00 unit override screen
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4.	 Click in the “Decimal Places” field to change the number of decimals displayed for an individual input-related unit 
in the Interval or Daily Logs. Up to seven decimal places are available.

5.	 Click OK.

Changing Default Decimal Display
To change all decimal places for every Interval and Daily archive file parameter without changing any other parameters, 

1.	 Uncheck the Override Units checkbox near the top of the screen to disable unit selection editing.

2.	 Click in the Override Decimal Places dropdown menu (Figure A.3) and select the number of decimal places to 
display. Up to seven decimal places are available.

3.	 Click OK.

 
Figure A.3—Scanner 2x00 decimal override selection 

Scanner 11xx Units
From the Scanner 11xx Viewing Options dialog, the user can change history settings, such as parameter names, decimal 
places, and column width, as well as unit settings, including unit categories, unit, and flowrun type settings to customize 
the presentation of data in the archive file.

Changing History Settings
To change the way a parameter is displayed in spreadsheets,

1.	 Select Scanner 11xx>History Settings (Figure A.4, page A-4).

2.	 Click in the “User Text” field for the desired category and type the name to be displayed. If no user text is entered, 
the default category name will appear.

3.	 Click in the “Decimal Places” field for the desired category and enter the number of decimal places to be displayed. 
The default setting is 3.
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4.	 Column width is defaulted to display on spreadsheets. To disable the columnar display for 11xx archive files, un-
check the Show checkbox to the left of “Column Width.”

5.	 To change the column width, click in the “Column Width” field and enter the desired width. The higher the number, 
the wider the column will be.

6.	 By default, all parameters are enabled to show. To remove a parameter, uncheck the Show checkbox.

7.	 Click OK.

Figure A.4—Scanner 11xx history settings 

Changing Units Settings
 To change the way units are displayed

1.	 Select Scanner 11xx>Units.

2.	 Click in the appropriate field in the “History” area or the “Configuration” area (Figure A.5, page A-5) and select the 
unit in which the archive file data will be viewed from the dropdown list.

Note	 The Gas, Liquid, and Monitor columns refer to the flowrun type defined in the archive file.

3.	 The “Default Units” area of the screen should be used when the flowrun type is not stored in the archive file. To 
change the default units, click the dropdown area next to a flowrun and select gas, monitor, or liquid for that flowrun. 

4.	 Click OK.
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Figure A.5—Scanner 11xx unit selections 
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Appendix B—Technical Support

Help Menu
The Help>About menu provides access to the Scanner Data Manager User Manual, phone and email contact information 
for regional Cameron offices, and a link for sending files to the nearest regional office.

Send File to Cameron
In the event that you need the help of a technician, Cameron provides a built-in email tool to help expedite the trouble-
shooting process. 

1.	 Select Help>Send File to Cameron Office (Figure B.1) and select the regional office nearest you from the drop-
down list provided. A new email window will open with the data file and the associated log file attached and the 
email address of the selected office pre-entered. If you know the email address of your primary Cameron contact, 
click on “Custom - Enter Contact” in the dropdown menu and enter the email address in the email window. 

2.	 Enter additional notes in the body of the email if desired and click Send.

Figure B.1—Help menu

CAUTION	  	 Scanner 3100 archive file (SDF) sizes may exceed 30 MB.  If your email host restricts the size of 
attachments, compress (zip) the archive file and reattach to the email before sending or contact 
Cameron for assistance. Scanner 2x00 and 11xx typically do not exceed 1.5 MB and many are 
smaller than 500 KB.

Technical Contacts
For phone numbers and email addresses for regional Cameron offices, select Help>About and click Technical  
Support.

     
Figure B.2—About Scanner Data Manager and Technical Support screens

B-1

Scanner Data Manager	  Appendix B



This page is left blank intentionally.

B-2

Appendix B	 Scanner Data Manager



WARRANTY - LIMITATION OF LIABILITY:  Seller warrants only title to the products, soft-
ware, supplies and materials and that, except as to software, the same are free from defects 
in workmanship and materials for a period of one (1) year from the date of delivery.  Seller 
does not warranty that software is free from error or that software will run in an uninterrupted 
fashion.  Seller provides all software “as is”.  THERE ARE NO WARRANTIES, EXPRESS 
OR IMPLIED, OF MERCHANTABILITY, FITNESS OR OTHERWISE WHICH EXTEND 
BEYOND THOSE STATED IN THE IMMEDIATELY PRECEDING SENTENCE.  Seller’s li-
ability and Buyer’s exclusive remedy in any case of action (whether in contract, tort, breach 
of warranty or otherwise) arising out of the sale or use of any products, software, supplies, 
or materials is expressly limited to the replacement of such products, software, supplies, 
or materials on their return to Seller or, at Seller’s option, to the allowance to the customer 
of credit for the cost of such items.  In no event shall Seller be liable for special, incidental, 
indirect, punitive or consequential damages.  Seller does not warrant in any way products, 
software, supplies and materials not manufactured by Seller, and such will be sold only with 
the warranties that are given by the manufacturer thereof.  Seller will pass only through to 
its purchaser of such items the warranty granted to it by the manufacturer.
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